Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Snap crashing with libgtk3-nocsd cannot be preloaded

Snap crashing with libgtk3-nocsd cannot be preloaded

For some reason, the snap package 1.0.72.117.g6bd7cc73-35 doesn't work on Ubuntu 18.04. It fails with:

 

ERROR: ld.so: object 'libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (failed to map segment from shared object): ignored.
execl failed: No such file or directory
child exited with status 1

Same for 1.0.77.315.g4d3f03c7-5 (edge).

Reply
9 Replies

Same; I was working just fine until an hour ago when I rebooted after doing updates. 

I removed and reinstalled, no difference. syslog shows no errors when I try launching spotify; from a terminal (and I didn't try this before it quit working so I don't really know if it should be working) I get this:

execl failed: No such file or directory
child exited with status 1

Ideas?

Tried the apt install, I get this:

The following packages have unmet dependencies:
 spotify-client : Depends: libcurl3 but it is not going to be installed
                  Recommends: libavcodec-ffmpeg56 but it is not installable or
                              libavcodec-ffmpeg-extra56 but it is not installable or
                              libavcodec54 but it is not installable or
                              libavcodec-extra-54 but it is not installable
                  Recommends: libavformat-ffmpeg56 but it is not installable or
                              libavformat54 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi,
I am using Ubuntu 18.04 beta. Spotify has worked until yesterday update. The snap application doesn't start. I tried to reinstall, change version etc.: 😞

I have exactly the same problem.

The latest update solved the problem.

Can confirm, late last night I ran updates and Spotify started working. I didn't tail the logs, it took a very long time to start up but it did come up. Yay!

+1

Hey guys,

    this thread is listing some bugs reports: https://community.spotify.com/spotify/board/message?board.id=desktop_linux&message.id=15902#M15902

related to the apt package.

 

The problem is that libcurl.so.3 can not cohabit with libcurl.so.4...

* https://launchpad.net/ubuntu/+source/curl/7.58.0-2ubuntu2

* https://bugs.launchpad.net/ubuntu/+source/curl/+bug/1754686

Hi all,

    @joon posted a solution in this thread:

Just replace the "stable" to "testing" in /etc/apt/sources.list.d/spotify.list, the run:

sudo apt update
sudo apt install spotify-client

Hope this works for you too!

Suggested posts