Sportify on Fedora 23 server - not starting due to libQtGui.so.4 error

Reply

Sportify on Fedora 23 server - not starting due to libQtGui.so.4 error

dieterv86
Casual Listener

Hi,

 

Been trying to get a Spotify client installed on my new Fedora 23 (64bit) server, but so far without any succes.

 

Tried first with the latest version of Spotify through the 'sudo yum -y install spotify-client' command, but this resulted in multipe errors.

I then got a tip to first try to install an older version of Spotify, though this guide:

https://gist.github.com/olejon/54473554be2d4dbacd03#file-install-spotify-stable-v-0-9-17-on-fedora-2...

 

I was able to complete all steps in the guide successfuly, resulting in Spotify 0.9.17 being installed.

However upon starting Spotify through the command line, I get this error:

 

spotify: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory

 

I went through tons of pages on google regarding similar issues, but I was unable to find a working solution so far, due to my very limited Linux knowledge (server is only a month old and so is my first Linux experience...)

 

Thanks for any pointers!

 

 

 

2 Replies

Re: Sportify on Fedora 23 server - not starting due to libQtGui.so.4 error

dieterv86
Casual Listener

I can't seem to find a delete button, but topic can be closed.

Continued to try several solutions to fix the problem this afternoon, which finally worked out, but I don't actually know which adjustment fixed the problem in the end as I've tried several, so can't provide much usefull informaiton for others with the same problem ;)

Re: Sportify on Fedora 23 server - not starting due to libQtGui.so.4 error

Jon74
Newbie

that's a shame, since I'm having problem on my 0.9.17.8 version on Fedora 

SUGGESTED POSTS