Spotify Client only works with VPN: Error code 117

Reply

Spotify Client only works with VPN: Error code 117

devnullca
Casual Listener

Plan: Premium

Country: Canada

Device: Lenovo Thinkpad X1Carbon

Operating System: Kubuntu Ubuntu 18.04.3 LTS

Linux Client 1.1.10.546.ge08ef575

 

Spotify client will only go online via my Windscribe VPN. If I disconnect the VPN, it goes into offline mode and I get Error code 4 "No Intenet connection detected"

If I start Spotify with the VPN disabled, I get error code 117 and it sits offline.
Tried the Shift-o keystroke to see if that would putit back online -- it didn't.

 

-There is no firewall to bypass, the network connection is good, the only app affected is Spotify.

-Tried deleting the cache diretory ~/.cache/spotify/

-Tried purging and reinstalling

-Same issue as this post: https://community.spotify.com/t5/Desktop-Linux/Error-code-117-on-Ubuntu-Desktop/m-p/4808369#M18900

-The app on a Windows machine in the network works fine, so it's not my ISP or my router throttling Spotify (unless the Linux client uses a different port or something).

-The apps on ipad, ipod, Android phoone, and even my Amazon Firestick all work fine.

-The web player works fine too.

 

Any ideas?

Update: Does this have anything to do with IPV6? I turned off my VPN and watched the logs.
dmesg and syslog report a segfault in Spotify

spotify[16211]: segfault at 31 ip 00007f79896287e2 sp 00007ffe0062a160 error 4 in libcef.so[7f79875c8000+5e37000]

 

kernel: [368247.333352] spotify[16211]: segfault at 31 ip 00007f79896287e2 sp 00007ffe0062a160 error 4 in libcef.so[7f79875c8000+5e37000]

 

and

systemd-resolved[736]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.

dhclient[32704]: XMT: Solicit on wlp4s0, interval 116070ms.

 

 

 

1 Reply
Highlighted

Re: Spotify Client only works with VPN: Error code 117

revyte
Songwriter

IPv6 should be fine, mine is working with v4 and v6.

 

It's something with your DNS.

- Try disabling/enabling DHCP and/or manual config.

- Check your resolv.conf, should point to /run/systemd/resolve/stub-resolv.conf and contains the nameserver/s.

SUGGESTED POSTS