Help Wizard

Step 1


Spotify continuously skips songs on linux

Spotify continuously skips songs on linux




Country: US



Generic PC

Operating System

Linux (Ubuntu 18.04 LTS)


My Question or Issue

Whenever I go to my linux workstation to fix a problem, sit down for coding or what else I may do I end up having this problem. This problem is persistent over many many installs of ubuntu 18.04 LTS and is honestly kinda frustrating. The issue makes it so I don't a chance to even hear any audio and instead just skips through my playlists or just refuses to play the songs and tells me to import... every time. So,  If any debugging information is required then tell me how to get that to you. I'm more than happy to help and get my jam on. FYI This I have encounted from spotify by installing from snap "stable" and the debian package aswell. The bugs are present on both. For demonstration see video below


58 Replies

Of course, Cornholio.  How dare we question the app that was provided out of the kindness of the developers' hearts?  What audacity, to expect the same quality service for our $10/mo that Windows users get!

I am having the same issue. I thought it was something to do with my drivers but it seems like multiple Linux users are seeing this same behavior as of today.


Most songs will play for a few seconds, there will be a jump in the track, and I'll get "Spotify can't play this right now. If you have the file on your computer you can import it."


Then, for some reason, 1 out of 5 or 1 out of 10 songs or so will play just fine. It's unpredictable and frustrating to troubleshoot. I've fiddled with just about every setting and deleted my cache, changed cache location, uninstalled/reinstalled.


I'm on Ubuntu 19.04.

I have been experiencing the same issue for the past ~8 hours.


OS: Pop!_OS (Ubuntu 19.04-based distro)

Environment: GNOME

Package Manager: snap

Spotify Plan: Premium


Only some songs (the vast majority of them) are affected. Spotify refuses to play those songs specifically and skips until it finds one of the very few songs it decided I should listen to. 


Troubleshooting done without success:

- Reinstall the package

- Restart PulseAudio (and the PC)

- Change audio devices

- Test for stable internet connection (ethernet, 0% packet loss, healthy connection)


Using Windows 10 on the same machine does not replicate the problem. Too bad that I need (and want) to spend most of my day on Linux.

Same problem here, im currently using ALSA but i see other people using other sound server programs and having the same problem.


Spotify version

Same here using Ubuntu. I'm new to this forum. Does Spotify pay attention here? I suggest we all contact Spotify support directly, and if necessary, repeatedly!

Official support here:

I'm new to this forum. Does Spotify monitor?

I suggest we each contact them directly:

I'm having the same issue. Spotify please fix or I will switch to AM where at least the linux client can't be dumpster fire because they dont have one in the first place.

Same issue here. Ubuntu 18 LTS, latest Spotify client 1:


I noticed the song stops, CPU goes to 15% then just skips to another track. Sometimes it just stays there without playing.

Yet another user having the exact same problem. Archlinux, latest. Was running through pulseaudio channeled into jack2, but even direct to my focusrite, no love. Exact same symptoms. Clearly a spotify issue, as I have been in Windows for about a week playing a game I just rented (a UWP-based game, so no, Proton wasn't gonna cut it), and Spotify worked just fine when I shut down and booted to Windows. Nothing was updated or changed in that time on my end or OS.


I pay for premium, so even though the linux port is 'unsupported' and a 'labor of love', (I totally don't mean this to sound like a "threat" to dump my subscription over this, but just being honest), but I know of a free method to do pretty much everything spotify does (actually technically better, because no DRM and I get to keep my downloaded tracks), but I'm paying for convenience and not having to store/stream my own library. Can't justify paying when the convenience factor doesn't apply anymore... So please fix it, because I actually like Spotify and am more than happy to keep paying for it, so long as it actually works.. Which it currently does not.

Same problem here since today. Spotify doesn't work in the app or web player. I hope it will be fixed, I pay for premium and I can't use spotify now.

Same thing happened to me just now
"Spotify can't play this right now. If you have the file on your computer you can import it."

Very sad when you have to pay for this


Constantly skipping songs

I didn't know that. 



Already posted this toppic to Spotiffy support twitter. We'll see.

So they "don't officially support linux".. But clearly there's an issue.. Not asking for support, asking for a working product. I guess if this is the attitude they're going to take, alright, I guess "I no longer support Spotify" is going to have to be my response. Again, I LIKE SPOTIFY and want to continue being a subscriber, but if that's the response they're giving to a valid issue, I can't continue to pay for convenience when that convenience doesn't actually exist anymore, and they don't care about fixing it. This isn't a feature request, it's basic functionality that most people here are paying for.


Not asking for much, just release a working product people pay for, and don't blow off paying customers. Seriously. What a terrible response. So much for a 'labor of love'.


If my response comes off as terse, well, it is. I can say it's because I'm paying for a service and not getting what I want, but really, that response above was ridiculous. This isn't asking for support, this is making them aware of and asking them to fix a problem... Only to be brushed off. That right there annoys me more than the fact that the player isn't working right. The response above has prompted me to fix my 'play' database and reimport my playlists there. I'm pretty certain I'm just done with spotify for now. Sorry.

I hope they do something about's a shame since most of us are Premium users.

What a **bleep**ing joke.

I understand that it's impossible to "support Linux", i.e. make Spotify work for every assclown with a **bleep**ed up Gentoo Stage 2 install and a super weird configuration.


Still, the Linux app is there to entice us into paying money, with the implicit promise that it will sort of work if you don't try to actively **bleep** it up.


It worked, since most of us on this thread did pay, apparently.

Now you have to keep it working, though.


The update they pushed is quite obviously broken and it's not working for any single one of us.


Fix it, move, hop along!

It must be a backend thing, you would think it shouldn't be too hard to just rollback whatever change broke the linux app until they can figure out what went wrong ¯\_(ツ)_/¯

My friend who runs 1.0.something on Arch has no issue.

Not 100% sure it's a backend thing.

Suggested posts