Help Wizard

Step 1


Spotify continuously skips songs on linux

Spotify continuously skips songs on linux




Country: US



Generic PC

Operating System

Linux (Ubuntu 18.04 LTS)


My Question or Issue

Whenever I go to my linux workstation to fix a problem, sit down for coding or what else I may do I end up having this problem. This problem is persistent over many many installs of ubuntu 18.04 LTS and is honestly kinda frustrating. The issue makes it so I don't a chance to even hear any audio and instead just skips through my playlists or just refuses to play the songs and tells me to import... every time. So,  If any debugging information is required then tell me how to get that to you. I'm more than happy to help and get my jam on. FYI This I have encounted from spotify by installing from snap "stable" and the debian package aswell. The bugs are present on both. For demonstration see video below


58 Replies

Yeah just a guess, I hadn't updated the client in a while and it just stopped working today. It's really annoying being a paying customer just to get the "we don't support linux" speech, we are just asking for a functioning client. Would be nice to at least get a straight answer (we are working on it would be enough for me) At least the web interface is prettier.

I have just done a clean install of Pop OS on an SSD, to use on the same laptop and this started. Just yesterday, I was listening fine on my old install. Could it be a version that is shoddy?

I'l try and get the old version from my old drive to see if the issue persists.

i dont think that'll help much.. i didnt even use my linux install for about a week, as soon as i booted it up it started acting up. a lot of these electron apps self-update the code.. i'd have to guess it has something to do with the DRM malfunctioning, but I honestly have no clue.

Alright, I feel a little better.. Linked to this thread as well, so hopefully it makes a difference. This is the response I was looking for, though I admit the one above still irks me... I did mention the thread, and he proactively asked for a link and spent time reading it. But the issue is known, now hopefully someone there can actually fix the issue. I asked if I could post a screenshot of his response, and he gave his okay, so sharing it with all of you. I'm still not sure what I'm going to do about my subscription. I'm just going to have to sleep on it and see how this issue works itself out before I come to a rational decision.. But at least they have a fighting chance now.


Yep, Ubuntu 18.04 and I have this problem too.

Hope it gets fixed quick.

All good here now, guys. Seems like they heard us. 

Yam, seems to be fixed.


Archlinux, latest spotify from AUR

Yeaa 😄
Thanks for the quick fix 🙂

Yea, all good here!

All fine here(Spotify from AUR)

Removed and installed it again using snap today, it's working fine now

Apparently it's fixed now (Ubuntu 19.04 with deb package, tested with two computers where it didn't work yesterday).


I didn't reinstall anything, so it seems like it was a server-side problem.

Yay it's fixed, but as I said before, it wasn't just a Linux problem... But oh wait.. I posted links to reddit threads of people on different platforms having issues (to show it wasn't a linux issue, and try to mediate peoples concerns about it being a linux specific issue), but that post has apparently been removed..


Wow, I really didn't realize how overmoderated this forum is... Considering Linux isn't officially supported, they sure police this forum as though it is. Really not sure what the point of deleting those posts were, as it was legitimate valid information regarding a problem we were trying to diagnose, and since this is a support forum where we're supposed to help each other out (since spotify doesn't actually officially support us), I really don't understand the reason for removing that post. It showed a pattern of problems on multiple platforms, which I'm sure people would have found useful.


I'm glad the issue is resolved, but please stop treating us like **bleep**. Deleting our posts, and blowing us off when we're having problems is unwarranted. I don't think anything I've asked for or have done to try to help others here is deserving of this hostility.


EDIT: I double checked the community guidelines, still no clue why it was deleted.. But I do want to mention, again, that this wasn't a linux-specific issue. I thought that was important enough to post yesterday, but apparently the moderators disagreed.

Still not working here.. guess I'll try re-installing 🤷

Still not working here either, just like the other guys here in the offfice.


11:17:57.963 E [cdn_chunk_downloader.cpp:367    ] Unknown resource size
11:17:57.963 E [cdn_chunk_downloader.cpp:317    ] CDN failure 0->524288. Error: download_no_size (5). Http: 416.

Trying to download that chunk by using wget with the URL from the log it seems to download just fine.


I already reinstalled, deleted settings and cache, tried the snap and the DEB version. No luck

I went back to version and everything works.

You can grab the DEB from the Mint repos:


Update: New Snap version works again.

Just happend to me now already a few times as well.
I fargot how to fix the problem, maybe I did with reinstalling spotify, but I dont wanna download all songs again.
But I can still contol the musik from my spotify app over the Pc.

I am on Windows 10

hope the bug get fixed.

I'm having the same issue but I'm using Windows 10. I've had the same issue on the Android app as well. It seems like a deeper problem with the Spotify player.

When this happens, Spotify just continuously skips through songs. In my case, it doesn't play any audio, just skips through tracks every fraction of a second, as if every song was just a split second of silence. It doesn't happen when using my laptop's built-in speakers but that's not a good workaround as I want to listen to music through my studio monitors.

I've tried uninstalling it and reinstalling it, changing the default audio device for Spotify in Windows settings, and running as administrator, but nothing has solved the issue. Spotify developers really need to step up and fix this problem. It's been an ongoing issue for me for years.

Suggested posts