Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify crashing Elementary (loki) wingpanel

Spotify crashing Elementary (loki) wingpanel

Everything was working perfectly until some days ago, but now every time I open the spotify app the wingpanel crashes. I'm not sure if it was an update on spotify itself or something within Elementary.


Syslog shows this:

Nov  1 12:49:15 saitama kernel: [11051.128510] wingpanel[5958]: segfault at 38 ip 00007fefabb5be2b sp 00007ffe7ca147a0 error 4 in[7fefabb4b000+27000]

Elementary version: Loki
Spotify version: 1:


I've tried to uninstall and reinstall spotify already, even tried the 0.9.17 version with the same effects. Also tried to uninstall some indicator apps, but nothing solved it.

I would like to know if anyone else has the same issue or if someone has any ideas of what could be happening.


Is there any way to install other versions of spotify? I've tried sudo apt install spotify-client=1:, but it couldn't find that version...

4 Replies

Never seen this before.


If wingpanel crashes, it is clearly a bug in wingpanel (which includes any library it might use). However, Spotify might also have a bug and do something bad, which triggers the crash in wingpanel.


Old versions of Spotify are unfortunately removed from the repository, when a new version appears, so you can't go back unless apt has kept a cached copy in /var/cache/apt/archives/


Thanks for the answer @jooon.


Actually I just found what was wrong, the bug is in a recent update on `wingpanel-indicator-sound`, it was updated to 2.0.3 a few days ago. I've already reported the bug to the project page and hopefully it should be fixed soon.


In the mean time there are 2 "fixes". It's possible to just remove the package and then Spotify and Wingpanel will play along just fine, but without the volume and sound indicator there, not that bad.
The 2nd option is to the build the 2.0.2 from source and install it, that's what I ended up doing until there's a fixed version.

Reinstalling the default video player (audience) seemed to fix it also for some reason, hopefully they just fix the bug soon

This fixed it for me too.

Suggested posts