[Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Solved!
Reply
Highlighted

[Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Casual Listener

Plan

Premium

Country

Denmark

Device

MacBook Pro late 2013

Operating System

Ubuntu 19.04 GNOME

My Question or Issue

Hi, 

I'm using the latest version of Spotify that I have downloaded from the Ubuntu Store.
I'm running Ubuntu 19.04 GNOME, and my scaling is set to 200%.

The Spotify client disregards the scaling.

I'm on my old MacBook Pro late 2013 with a retina display (2880x1800).  

 

I do not know where to post the bug or issue, so here it is.
I hope this will help some and eventually fix my problem. 🙂

Screenshot from 2019-08-01 16-48-30.png
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution!

Re: [Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Regular

There are a few threads on this - search for "hidpi linux"

Try starting Spotify from a terminal:

 

      spotify --force-device-scale-factor=2.0

 

You can use a different scaling factor than 2 if you want. You can try 1.5 if 2.0 isn't right for you.

 

Then you can try editing:

/usr/share/applications/spotify.desktop

 

Replace:

Exec=spotify %U

 

With:

Exec=spotify --force-device-scale-factor=2.0 %U

 

This appears to work for most people.

View solution in original post

3 Replies
Highlighted
Solution!

Re: [Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Regular

There are a few threads on this - search for "hidpi linux"

Try starting Spotify from a terminal:

 

      spotify --force-device-scale-factor=2.0

 

You can use a different scaling factor than 2 if you want. You can try 1.5 if 2.0 isn't right for you.

 

Then you can try editing:

/usr/share/applications/spotify.desktop

 

Replace:

Exec=spotify %U

 

With:

Exec=spotify --force-device-scale-factor=2.0 %U

 

This appears to work for most people.

View solution in original post

Highlighted

Re: [Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Casual Listener

Fantastic help you gave me there! It works perfectly with 2 times scaling.
The mouse does not scale with it though. (This is not a problem)

 

The desktop file was located at: 

/var/lib/snapd/desktop/applications/spotify_spotify.desktop

 

Properly because the store is using the snap version. 🙂 

 

 

Screenshot from 2019-08-02 17-08-50.png
Highlighted

Re: [Ubuntu][19.04][GNOME] Spotify is not scaling with GNOME

Newbie

The cursor scaling issue seems to be specific to the Snap package - I reinstalled Spotify from the Flatpak (https://flathub.org/apps/details/com.spotify.Client), and the cursor is the correct size. (I also didn't have to add the --force-device-scale-factor flag, although at the moment I'm still a bit confused about why not...)

 

Edit: It's not just the size of the cursor, btw - on the Snap install the cursor theme isn't respected either. It's not apparent on the default Yaru theme, but if you use a theme with a white cursor, the cursor turns black when you move it over Spotify. This is also not the case with the Flatpak.

 

SUGGESTED POSTS