Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Ubuntu 19.04 deb package segfault

Ubuntu 19.04 deb package segfault


Plan Premium

Country US

Device Laptop

Operating System Ubuntu 19.04


My Question or Issue

Spotify is crashing with the latest update (1.1.5); rolling back to 1.0.98 solved the issue.

The issue seems to be with curl and gnutls, though I don't want to post logs because they're quite revealing I believe.

86 Replies

The link to the libcurl3 package posted above does not work anymore because the package has been updated (now libcurl3-gnutls_7.64.0-4 instead of libcurl3-gnutls_7.64.0-3).

The following links work; installing these two packages fixed the issue:

needed to install libgnutls30_3.6.8-2_i386 as well.

up to date links are:


curl -o ~/Downloads/libgnutls30_3.6.8-2_amd64.deb 

curl -o ~/Downloads/libgnutls30_3.6.8-2_i386.deb -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb


I understand that there might be  issues with the TLS libraries, but as many other produts are also working with these, a workaround should be possible.

I am disapointed that nobody from the spotify developers (yes I know not officially supported) has an eye on this and come up with an updated spotify client.



same proble here with Ubuntu 19.04 and Spotify


I delete some user files and it works again :

$ rm -rf ~/.config/spotify

I am getting still SIGSEGV, even with version 1:

Thank you, that seems to work for me as well 🙂



Works 😄 i had to install libssh2-1 to get everything to install. popos! (Ubuntu based) my guess is same apply to ubuntu 😄

libgnutls30_3.6.8-1_amd64.deb is not available anymore (404)

Ah yeah, this solved my problem with Spotify! Although I got an error:

dpkg: Fehler beim Bearbeiten des Paketes libgnutls30:i386 (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert

Translated: "Dependency Issues - Remains Unconfigured"


@brisssou wrote: -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

Sorry for a stupid question, but is this command meant to start with `curl` at the beginning (a Linux newbie that I am). Anyway, by doing so, I was able to download all of the three .deb files: 1) libcurl3-gnutls_7.64.0-4_amd64.deb, 2) libgnutls30_3.6.8-2_i386.deb, and 3) libgnutls30_3.6.8-2_amd64.deb


However, when trying to execute the last command, I'll get this:


panteroide@ubuntu:~$ sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb
[sudo] password for panteroide: 
(Reading database ... 183422 files and directories currently installed.)
Preparing to unpack .../libcurl3-gnutls_7.64.0-4_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.64.0-4) over (7.64.0-2ubuntu1.1) ...
Preparing to unpack .../libgnutls30_3.6.8-2_amd64.deb ...
Unpacking libgnutls30:amd64 (3.6.8-2) over (3.6.5-2ubuntu1.1) ...
Selecting previously unselected package libgnutls30:i386.
Preparing to unpack .../libgnutls30_3.6.8-2_i386.deb ...
Unpacking libgnutls30:i386 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libcurl3-gnutls:amd64:
 libcurl3-gnutls:amd64 depends on libssh2-1 (>= 1.7.0); however:
  Package libssh2-1 is not installed.

dpkg: error processing package libcurl3-gnutls:amd64 (--install):
 dependency problems - leaving unconfigured
Setting up libgnutls30:amd64 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libgnutls30:i386:
 libgnutls30:i386 depends on libgmp10 (>= 2:6.0.0).
 libgnutls30:i386 depends on libc6 (>= 2.28).
 libgnutls30:i386 depends on libhogweed4 (>= 3.4.1~rc1~).
 libgnutls30:i386 depends on libidn2-0 (>= 2.0.0).
 libgnutls30:i386 depends on libnettle6 (>= 3.4~).
 libgnutls30:i386 depends on libp11-kit0 (>= 0.23.11).
 libgnutls30:i386 depends on libtasn1-6 (>= 4.12).
 libgnutls30:i386 depends on libunistring2 (>= 0.9.7).

dpkg: error processing package libgnutls30:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.29-0ubuntu2) ...
Errors were encountered while processing:


 Any ideas how to proceed? 😞


I tried to launch Spotify through terminal as well, but it yielded me with the following error message:


panteroide@ubuntu:~$ spotify
spotify: error while loading shared libraries: cannot open shared object file: No such file or directory

I just really, really hope I could get my dear Spotify to work again. 😞

@Morno wrote:



Works 😄 i had to install libssh2-1 to get everything to install. popos! (Ubuntu based) my guess is same apply to ubuntu 😄

I am running Linux Ubuntu Pop!_OS 19.04 as well, and seems like a similarly named package is missing, ``? Do you think that is the same one? Perhaps you could hint me how exactly you did install it? Thanks a lot! 🙂

Also running Pop_OS! here (19.04). Using some of the earlier posts I got it working after doing the following. If the last command doesn't work, run 'apt --fix-broken install' and try the last command again. After doing this it started working for me!

sudo apt install libssh2-1

curl -o ~/Downloads/libgnutls30_3.6.8-2_amd64.deb 

curl -o ~/Downloads/libgnutls30_3.6.8-2_i386.deb 

curl -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb

The reason for this is, as far as I understand it, is that there is a missing patch in the libcurl3-gnutls package in Ubuntu based distributions. However Debian has patched their version of the package. And so installing their version of the package (and its needed dependencies) will get it working.

@0x783czar thanks! I think you've compiled all the best-practices available on your post! 🙂

As of today (?) Spotify seems to be working just fine on my Pop!_OS (Ubuntu 19.04). And I did not make any changes.

Doing this before every start of Spotify helps. What a pain.


rm -r $HOME/.cache/spotify

Works nicely.

I have the same problem with the snap package too. Ubuntu 19.04, amd64.

The libgnutls30_3.6.8-2_i386.deb and libcurl3-gnutls_7.64.0-4_amd64.deb packages seem no longer available, so I ended up installing the following packages on Ubuntu 19.0 to make it work:


Ben careful with this one, messes things up when installing manually. If you know what you're doing it's akay. Otherwise, beter wait.





It is actually better to use packages from an Ubuntu Mirror, because right now, Debian's testing distribution has a newer libcurl3-gnutls version than Ubuntu's testing version. And five days before the final freeze of Ubuntu 19.10 it is quite possible that 19.10 will come with libcurl3-gnutls 7.65.x. So by installing Debian testing's curl and gnutls libraries, one's system will even remain messed up after upgrading to 19.10.

However, if one does not plan to upgrade to 19.10 after its release, one should make sure to use the Debian Buster packages and not the testing ones.

Suggested posts