Ubuntu 19.04 deb package segfault

Reply

Ubuntu 19.04 deb package segfault

yuusou
Regular

 

Plan Premium

Country US

Device Laptop

Operating System Ubuntu 19.04

 

My Question or Issue

Spotify is crashing with the latest update (1.1.5); rolling back to 1.0.98 solved the issue.

The issue seems to be with curl and gnutls, though I don't want to post logs because they're quite revealing I believe.

86 Replies

dlu
Gig Goer

Issue is outdated, Ubuntu 19.10 is out 😉

yuusou
Regular

Fixed in Ubuntu 19.10.

It only took 6 months to get fixed. ¯\_(ツ)_/¯

Obviously of no effort from the Swedish behemoth.

thereal_rjf
Gig Goer

The problems were due to third party libraries in Ubuntu, not Spotify's code. It takes time for updated libraries to make it into Linux distributions.

 

It's not helpful to have a pop at Spotify for this. The app was seg faulting on a given linux distribution for bugs which were not in their code. This is a project that appears to be done mainly from the good will of staff interested in making a Linux offering as opposed to leaving us completely in the cold, like most commercial organisations.

Funeoz
Regular

I don't know why but I get this error : [1123/164403.997336:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
I am running on Kubuntu 19.10 and I have the latest libcurl3-gnutls (7.65.3-1ubuntu3) and libgnutls30 (3.6.9-5ubuntu1). So I just get the grey background of spotify and nothing loads.

alex22p22
Music Fan

I'm not sure if the error message posted above is related to your problems. Many people get that error message and their Spotify is working fine. However you can get rid of the message, by telling the client to not use accelerated graphics features.

 

This is what I get with default startup:

 

$ spotity 

[1124/123514.597695:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command

 

Modified startup:

 

$ spotify --disable-gpu 

 

No error message.

Funeoz
Regular

I tried it. I don't get the error anymore but the client is still not loading.

-olo-
Visitor

Worked for me using the versions:

 

dpkg --list | grep gnutls

ii libcurl3-gnutls:amd64 7.64.0-4 ...
ii libgnutls30:amd64 3.6.7-4 ...
ii libgnutls30:i386 3.6.7-4 ...

 

cat /etc/lsb-release

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=19.04
DISTRIB_CODENAME=disco
DISTRIB_DESCRIPTION="Ubuntu 19.04"

... with Mint desktop

SUGGESTED POSTS