Ubuntu 19.04 deb package segfault

Reply

Re: Ubuntu 19.04 deb package segfault

dpirch
Casual Listener

The link to the libcurl3 package posted above does not work anymore because the package has been updated (now libcurl3-gnutls_7.64.0-4 instead of libcurl3-gnutls_7.64.0-3).

The following links work; installing these two packages fixed the issue:

Re: Ubuntu 19.04 deb package segfault

brisssou
Regular

needed to install libgnutls30_3.6.8-2_i386 as well.

up to date links are:

 

curl http://ftp.us.debian.org/debian/pool/main/g/gnutls28/libgnutls30_3.6.8-2_amd64.deb -o ~/Downloads/libgnutls30_3.6.8-2_amd64.deb 

curl http://ftp.us.debian.org/debian/pool/main/g/gnutls28/libgnutls30_3.6.8-2_i386.deb -o ~/Downloads/libgnutls30_3.6.8-2_i386.deb 

http://http.us.debian.org/debian/pool/main/c/curl/libcurl3-gnutls_7.64.0-4_amd64.deb -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb

sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb

Re: Ubuntu 19.04 deb package segfault

cnbnjn
Casual Listener

Hi,

I understand that there might be  issues with the TLS libraries, but as many other produts are also working with these, a workaround should be possible.

I am disapointed that nobody from the spotify developers (yes I know not officially supported) has an eye on this and come up with an updated spotify client.

 

chris

Re: Ubuntu 19.04 deb package segfault

Leokun
Newbie

same proble here with Ubuntu 19.04 and Spotify 1.1.5.153

 

I delete some user files and it works again :

$ rm -rf ~/.config/spotify

Re: Ubuntu 19.04 deb package segfault

rushlife
Casual Listener

I am getting still SIGSEGV, even with version 1:1.1.10.546.ge08ef575-19

Re: Ubuntu 19.04 deb package segfault

hvontres
Newbie

Thank you, that seems to work for me as well :)

Re: Ubuntu 19.04 deb package segfault

Morno
Casual Listener

Thanks!

 

Works :D i had to install libssh2-1 to get everything to install. popos! (Ubuntu based) my guess is same apply to ubuntu :D

Re: Ubuntu 19.04 deb package segfault

carlolf
Regular

libgnutls30_3.6.8-1_amd64.deb is not available anymore (404)

Re: Ubuntu 19.04 deb package segfault

carlolf
Regular

Ah yeah, this solved my problem with Spotify! Although I got an error:

dpkg: Fehler beim Bearbeiten des Paketes libgnutls30:i386 (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert

Translated: "Dependency Issues - Remains Unconfigured"

 

Re: Ubuntu 19.04 deb package segfault

Panteroide
Regular

@brisssou wrote:

http://http.us.debian.org/debian/pool/main/c/curl/libcurl3-gnutls_7.64.0-4_amd64.deb -o ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb


Sorry for a stupid question, but is this command meant to start with `curl` at the beginning (a Linux newbie that I am). Anyway, by doing so, I was able to download all of the three .deb files: 1) libcurl3-gnutls_7.64.0-4_amd64.deb, 2) libgnutls30_3.6.8-2_i386.deb, and 3) libgnutls30_3.6.8-2_amd64.deb

 

However, when trying to execute the last command, I'll get this:

 

panteroide@ubuntu:~$ sudo dpkg -i ~/Downloads/libcurl3-gnutls_7.64.0-4_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_amd64.deb ~/Downloads/libgnutls30_3.6.8-2_i386.deb
[sudo] password for panteroide: 
(Reading database ... 183422 files and directories currently installed.)
Preparing to unpack .../libcurl3-gnutls_7.64.0-4_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.64.0-4) over (7.64.0-2ubuntu1.1) ...
Preparing to unpack .../libgnutls30_3.6.8-2_amd64.deb ...
Unpacking libgnutls30:amd64 (3.6.8-2) over (3.6.5-2ubuntu1.1) ...
Selecting previously unselected package libgnutls30:i386.
Preparing to unpack .../libgnutls30_3.6.8-2_i386.deb ...
Unpacking libgnutls30:i386 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libcurl3-gnutls:amd64:
 libcurl3-gnutls:amd64 depends on libssh2-1 (>= 1.7.0); however:
  Package libssh2-1 is not installed.

dpkg: error processing package libcurl3-gnutls:amd64 (--install):
 dependency problems - leaving unconfigured
Setting up libgnutls30:amd64 (3.6.8-2) ...
dpkg: dependency problems prevent configuration of libgnutls30:i386:
 libgnutls30:i386 depends on libgmp10 (>= 2:6.0.0).
 libgnutls30:i386 depends on libc6 (>= 2.28).
 libgnutls30:i386 depends on libhogweed4 (>= 3.4.1~rc1~).
 libgnutls30:i386 depends on libidn2-0 (>= 2.0.0).
 libgnutls30:i386 depends on libnettle6 (>= 3.4~).
 libgnutls30:i386 depends on libp11-kit0 (>= 0.23.11).
 libgnutls30:i386 depends on libtasn1-6 (>= 4.12).
 libgnutls30:i386 depends on libunistring2 (>= 0.9.7).

dpkg: error processing package libgnutls30:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.29-0ubuntu2) ...
Errors were encountered while processing:
 libcurl3-gnutls:amd64
 libgnutls30:i386
panteroide@ubuntu:~$ 

 

 Any ideas how to proceed? :-(

 

I tried to launch Spotify through terminal as well, but it yielded me with the following error message:

 

panteroide@ubuntu:~$ spotify
spotify: error while loading shared libraries: libssh2.so.1: cannot open shared object file: No such file or directory

I just really, really hope I could get my dear Spotify to work again. :-(

SUGGESTED POSTS