"Spotify can't play this right now.", ffmpeg 3.4.2 installed, audio in other apps working perfectly

Reply

"Spotify can't play this right now.", ffmpeg 3.4.2 installed, audio in other apps working perfectly

JannickBremm
Newbie

Plan

Premium

 

Country

Germany

 

Operating System

Arch

 

My Question or Issue

The title says everything. I installed Spotify via snap. This seems to be a known problem. Are there any other (less ridiculous) fixes than installing a three year old ffmpeg version?

"Thank's"

1 Reply

JasonLG1979
Composer

No, not really. The Spotify Linux desktop app is basically hot garbage and among other things depends on an ancient version of ffmpeg.

Sad but true, if you want the best experience use the unofficial flatpak. It's at least maintained by people who actually care about Linux users and we do our best to fix/workaround what we can. It still uses ffmpeg 3.4.x but at least you don't have to worry about keeping track of it and it's confined to the flatpak container.  


SUGGESTED POSTS