Announcements

Ads won't play, can't be skipped, can't play music

Ads won't play, can't be skipped, can't play music

ehryn

Brief description of the issue: Every now and then an ad that says "you can skip this ad after 5 seconds" comes along, and... won't play. Nor can I skip it, or choose a song. In fact, often it completely crashes my spotify client and I have to force close it. It's only happening on these specific ads, any other ads are all fine, but these 'wait 5 secs' ads are absolutely infuriating, because I have to close Spotify and reopen it in order to start playing music again. And, if it's the very first ad I come across it means doing it sometimes after just one song depending on when the first ad shows up (which is sometimes after the very first song I play). 

 

Steps to reproduce the issue:

  1. I cannot reproduce this issue, it happens completely at random. 

What steps you’ve tried already: I have tried updating my Spotify client (it says there are no updates), deleting and redownloading my client, and the old 'turn it off and on again' by closing and reopening it. This has been going on for months but since it used to happen maybe 1/2 times a day and is now happening basically once an hour, I would really appreciate a fix.

 

Your device and operating system (e.g. MacBook Air, 10.10 OSX): Macbook Pro 13 inch, OSX El Capitan Version 10.11.6

Type of Spotify account you have (Free/ Premium): Free

The app version of Spotify you’re using: 1.1.5.153.gf614956d

Reply
8 Replies

Loxer

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? Sorry if this may sound a bit repeptitive but if that doesn't help, try a quick clean reinstall of the app by following these steps.

 

Could you also try connecting to another internet connection to see if that helps?

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

ehryn
Hi, sorry, I didn't get a notification and honestly totally forgot to check back here sooner! I have restarted my device several times, as well as the app, and deleted/redownloaded it, but nothing has made a difference - the issue still happens! (Which is what reminded me to come and check back here.) And it happens whether I'm at home, at work, or using my mobile data - though I should mention it doesn't happen when I'm listening via my phone app, only on my Macbook. Here's my device and client details: Your device and operating system (e.g. MacBook Air, 10.10 OSX): Macbook Pro 13 inch, OSX El Capitan Version 10.11.6 Type of Spotify account you have (Free/ Premium): Free The app version of Spotify you’re using: 1.1.5.153.gf614956d Thanks for your help.

Peter

Hey @ehryn.

 

Thanks for getting back to us 🙂

 

I know you mentioned that you don't experience this issue on your phone, just to confirm this isn't an account issue, do you mind creating a new free account and seeing if you're still unable to skip those ads?

 

Keep us posted - we'll be here to help if you still need it 😉

marek77

Hello,

 

I have the same issue. I have a free subscription, the Spotify client on Fedora Linux, version spotify-client-1.1.56.595.g2d2da0de-1.fc34.x86_64 (latest) and the "freeze" started happening a couple of days ago, possibly with the latest update. The playback stops at the beginning of ads (the ad never plays) and skip/pause/play buttons don't work. I cannot choose another playlist/artist/song to play neither (UI is responsive but as the ad has not played it doesn't allow to play anything else). When I restart the client the ad is no longer there and the next song can be played. This doesn't happen with all ads though, and I cannot identify which are the "bad" ones as it only says "advertisement". 

 

I have never had this issue with the Android app.

Alex

Hey @marek77,


Thanks for reaching out about this in the Community!

 

Spotify is not actively supported on Linux so we can't guarantee that the app would work flawlessly. 

 

Some things you can try are to uninstall the app, clear all app data and re-install. Check if you can switch Hardware Acceleration OFF from the Settings.

 

Also, make sure that Spotify is not blocked by any firewall or system management software.

 

Hope this helps.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

marek77

Hello,

 

thanks for a quick reply. I know that the Linux is not officially supported, but it's an Electron app so I guess that differences between Linux and other platforms are not enormous.

 

I have no Hardware Acceleration in the settings (I went into Advanced settings as well). I'll try to delete the app data as suggested and report back.

 

Thanks.

marek77

Hello,

 

I have deleted whole folder $HOME/.cache/spotify but the client got stuck on a ad again (in the meantime, the PC was also restarted). I don't have any ad blocking on the firewall level.

 

I used to use the web client and I switched to the app because of playback problems...

I guess I'll need to wait for a client update which would fix this 😞

Screenshot_20210512_190733.png

CarlosE

Hey @marek77,

 

Thanks for keeping in touch.

 

We're sorry to hear that it didn't work. While waiting for an update, we suggest heading over to this board where you can find suggestions from fellow Linux users that might be of help.

 

If you need anything else, we'll be right here.

 

Take care!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Suggested posts

Env: prod