Announcements

Black screen, app don't work

Reply
Highlighted

Black screen, app don't work

Casual Listener

Plan

Premium

Country

Brasil

Device

MacBook Pro 13 

 

I just had the app installed and it won't leave this black page. I already tried to reinstall but it stays like this. How I can solve this issue?

 

Screen shot of the issueScreen shot of the issue

Operating System

iOS High Sierra 10.13.5

 

My Question or Issue

 

8 Replies
Highlighted

Re: Black screen, app don't work

Rock Star 16
Rock Star 16

Hi,

 

Please check these articles, 1 & 2.

They might help solve your issue.

Please next time try to look up for your issue in the community since it might have been solved before.

 

Have a nice day 🙂

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Black screen, app don't work

Casual Listener

Hi,

I had already checked this 2 articles, my problem is on Mac and the articles are about Windows. I still have this problem and I have no clue how to solve it.

Highlighted

Re: Black screen, app don't work

Rock Star 16
Rock Star 16

Hi,

 

I don't know if you even opened the links but the first one is for macOS while the second has a thread on it that is for macOS.

Anyway, since you have checked these 2, here are some others that are worth a check for real this time. 3, 4 & 5

 

Have a nice day 🙂 

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Black screen, app don't work

Newbie

#5 was a lifesaver. None of the other links were helpful for me. Tip number two in this link was what finally got my app working. Thank you for posting these other links. 

Highlighted

Re: Black screen, app don't work

Rock Star 16
Rock Star 16

Glad that it worked 😄

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Black screen, app don't work

Casual Listener

I've looked through the 5 threads that you linked here, and none of them fixed the issue for me.  When I start Spotify, it is only black, not a single word of text or image is visible in the app for 20 minutes or longer.  

Screen Shot 2020-09-10 at 11.39.22 AM.png

Then the Home page loads and the left menu bar loads, but if I click on any other page (ex. Browse, Radio) or playlist, the screen is blank/black again.

Screen Shot 2020-09-10 at 11.46.40 AM.png

 

  • I've deleted the app and all cache and other application files and reinstalled the latest version.
  • I've disabled hardware acceleration.
  • I've run the application using this command: /Applications/Spotify.app/Contents/MacOS/Spotify --disable-accelerated-layers --disable-accelerated-fixed-root-background 
  • I checked the "prefs" file for any proxy settings -- there are none.
  • I don't have a separate graphics card.
  • I deleted the "ru.mo" file and the "en.mo" file in the locales folder.
  • Spotify was not listed in the Login Items of my Mac.
  • I couldn't locate this file/plugin: /Library/Application Support/SIMBL/Plugins/SpotifyRemotePlugin.bundle

 

I don't know what other steps to take.  This issue started happening 3 days ago, seemingly out of the blue.  I did not update my MacOS, I'm still using the same computer, I don't know what else could have changed.

Highlighted

Re: Black screen, app don't work

Moderator
Moderator

Hey @ronsbons ,

 

Thank you for letting us know about this. No worries - We're here to help 🙂

 

Can you let us know which device/devices this happen on?

 

Could you try to log in to another Spotify account on the device/devices this occurs on? You can use a friend or a family members account if it's possible and let us if the issue persists.

 

It would also be great if you could send us a screen recording of what's going on. It would help us understand more what's going on directly from your end.

 

We're looking forward to your reply. 

 

Cheers! 

XeniaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Where words fail, music speaks." - Hans Christian Andersen
Highlighted

Re: Black screen, app don't work

Casual Listener

Hi @Xenia,

 

Thanks for replying!

 

This WAS happening on a 2017 13-in MacBook Air with macOS Catalina (10.15.6).  I don't know what the difference is between the past 4 or 5 days and today, but somehow, it's magically working now...

 

I'll come back if the issue happens again!

SUGGESTED POSTS