Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Black screen for Spotify Mac Desktop

Black screen for Spotify Mac Desktop

Hello to everyone,

 

It's been a while that I can't use Spotify on Mac (Catalina 10.15.3), I just have a black screen.

Of course I re-instal many times, I also disabled hardware acceleration. Some previous help told my to change lines of code on the library, but It did not work either.

Nothing change, and I am annoyed now. 

 

Do you please have any idea how to fix that ?

Thanks a lot !

Screenshot 2020-04-03 at 10.32.49.png
Screenshot 2020-04-03 at 10.32.57.png
Reply
Top Answer
sam-114
Casual Listener
Top Answer
dvukmiro
Casual Listener
Copying and pasting the link made all the difference! Thank you.
69 Replies

https://www.youtube.com/watch?v=4g2VWCHHEpU

 

this video explains it well.

This video helped the problem.

https://www.youtube.com/watch?v=4g2VWCHHEpU

Hi there @sam-114,

 

Thank you for your reply in this thread.

 

It's really nice of you to share what worked for you to the other users 🙂

Let us know if we can help you with anything else.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

wow, took me long enough to find this answer T^T, was starting to get frustrated, this worked for me in an instant, great help, thank you very much!

None of the above is working on my imac intel running catalina. HELP!!

I tried updating, uninstalling, reinstalling, updating my OS, you name it. Nothing worked except this. thank you for posting. 

It works until you try to restart Spotify again.

Hi, did you hold down the option key so that the library came up?

Screenshot 2021-11-03 at 10.39.25.png

Spotify, please actually fix this problem! Deleting the prefs file every time I close the app is not a fix. This issue has nothing to do with individual computers, but is a developer flaw in the app itself as it relates to the Mac OS. 

 

I've had this problem on multiple Macs with the last two MacOS versions. 

 

Logging in with a different account doesn't work either once you restart the app, it goes black. 

 

I've reinstalled the app as well...no difference. 

 

Please go back to the developers and create an actual fix and push an app update. Thanks

Use text editor to edit the file:
~/Library/Application Support/Spotify/prefs

Add this line:
language="en"

Then restart Spotify, the login window shows like a charm.
The solution works for me, hope it helps you!

Deleting prefs and caches doesn't fix, but adding the language configuration works. ( maybe for my system language is zh-CN. Please fix this issue Spotify!)

Yes!!! THIS worked. All the other steps did not help at all. 

In finder command+shift+G then search ~/Library/Application Support/Spotify/prefs and delete the prefs, and reopen Spotify and you're golden. 

Shocking this is still going on.

Mac OS X 12.2.1 and need to randomly delete the perfs file - nothing else works.

Hi there,

I have the same problem.

To be frank... I'm really not a fan of Spotify -- but my family wants it... so I try to use it as well and bought a premium account. In short: I pay for this stuff.

 

Everytime I start the application, the screen is black. It's NOT A SOLUTION to delete always this prefs-file. Maybe fixing the error within the application would be a solution? 

 

But as long as this problem isn't fixed, I'm already re-thinking deleting my premium account.

Hey @mozosworld,

 

Thanks for your reply in this thread 🙂

 

Can you give us more details about your device operating system? Also, did you notice if this happens on another device as well?

 

On another note, could you share with us the troubleshooting you’ve already done? You could start with a clean reinstall to see if this makes a difference. You can see the steps for a clean reinstall here.

 

We'll be on the lookout for your reply.

 

​​​​​​​​​​​​​​Until then!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

It's an Apple macOS Monterey Version 12.3.1 (current version).

Deleting and re-install doesn't work.

Seriously, sort this out. 

This has been happening on every M1 machine I own for months now. 

This is my Macbook Air...

 

Hardware Overview:

 

  Model Name: MacBook Air

  Model Identifier: MacBookAir10,1

  Chip: Apple M1

  Total Number of Cores: 8 (4 performance and 4 efficiency)

  Memory: 8 GB

  System Firmware Version: 7459.101.2

  OS Loader Version: 7459.101.2



Doesn't matter what account, how many times I reinstall, delete preference file, add language "en" or whatever, it is a seriously software flaw.



Hey @gizze,

Thank you for reaching out to the Community and for the info shared.

Just to make sure, have you deleted the "prefs" folder as mentioned in the video sent in previous posts by @sam-114? If so and the issue persists, could you confirm if you use these steps for a clean reinstall? They are more thorough than a regular one. That way you can make sure the cache is not causing this issue.

Lastly, would you mind sending the Spotify version you're currently running on your device? This will give us a better look to keep investigating your case.

We'll be on the lookout. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It's been a bug for years. I don't understand why your customer support was not seeing this issue over the internet.  Just search "Spotify black screen", and you will see astonishing results.

2 years ago , I have fist countered this problem and solve it by using command in console

mv /Applications/Spotify.app/Contents/Resources/locales/zh-Hant.mo /Applications/Spotify.app/Contents/Resources/locales/zh-TW.mo

Then I haven't used Spotify until today, and the problem suddenly appeared again with the same bug. No any other word to say it...

Hi there @koweichen,

 

Thank you for your reply in this thread. We're super sorry to see that you're experiencing this. Let's take a closer look into this together.

 

To start with, can you let us know the troubleshooting you've done which has been provided in this thread?

 

We'll be on the lookout for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts