Help Wizard

Step 1

NEXT STEP

Can only play playlists, albums not working

Can only play playlists, albums not working

Plan

Premium

Country

Uk

 

Device

MacBook Air Early 2015

Operating System

macOS Catalina version 10.15.6

 

My Question or Issue

Spotify App only now plays playlists, very occasionally it will play the odd album, but only the first track, Most albums will not play at all and pressing play brings nothing up on the screen.

Reply
41 Replies

Hi! I had the same issue (only playlists worked) but the problem disappeared when I disconnected from my work VPN.

Hello, I had the same issue, Spotify not playing songs from other than playlists on Windows 10 21H1. I have F-Secure Freedome VPN, turning the VPN connection off resolved the issue for me. Goodbye.

Having the same problem. Can attest to the VPN thing, turned off kill switch and disconnected from Nord and everything worked fine up until I turned it back on.

Can confirm: disabling my VPN (Mullvad) resolves the issue.

 

Other info:

- Running the Spotify web app allows me to play everything as expected.

- Playing popular songs and albums did not work on the desktop app (prior to disabling my VPN).

- Playing some popular songs can work when you open a song radio. Then, when returning to the popular songs, only the songs that appeared in the song radio playlist are now able to play. This might be useful debugging info for developers.

I have had this issue for a long time now and I have tried every single troubleshooting method suggested to me, nothing ever worked. Today I tried turning off my VPN. It solved that problem for me. So if you have a VPN on, turn it off, play a song and turn VPN back on. You should now be able to play songs from artists or albums. I'm not sure if it only fixes it momentarily, but that worked for me for now.

For me it resolves for a period of a day to a week before I need to turn my VPN off again.

1) Clear the cache & data

2) reinstall the app

3) sing out of all accounts but nothing worked so far. Even with only 1 downloaded Album it is simply not loading the Album. When I remove the "download filter" I sometimes can open an Album that is not downloaded.

 

Regards,

Will

Hey there @William241,


Thanks for the post and for sharing your troubleshooting.

 

Have you tried disabling your VPN if using one?

 

Let us know.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Still having issues with this. I have tried all solutions I could find and still no luck. Has anybody found the solution to this yet?

Hey @jamieblackmore,

 

Welcome to the Community and thank you for joining the conversation.

 

One of the main causes of this issue is having an active VPN since it creates a virtual private connection that makes the data transfer more difficult adding some security protocols. If you have any VPN active, we'd recommend disconnecting from it and trying again.

 

If the issue persists, could you check if using a different Wi-Fi network makes any difference? In case you don't have another one available, you can use a mobile data hotspot to test it.

 

Let us know how it goes.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Having same issue I can not select individual songs on the desktop application unless they are in a playlist. Tried all of the "solutions". No luck.

Hey @EliotACG,

 

Thanks for the reply.

 

Could you list the troubleshooting steps you've already tried so we can extend them with new proposals?

 

It's important to not have a VPN turned on. Is this the case on your end?

 

Keep us posted,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hey, it looks like I have the same issue. I don't have any VPN Services installed and I also restinalled the App multiple times in multiple ways and nothing changed. Are there any other possible solutions?
The Web and Mobile Application works fine for me, but I prefer to use the Desktop Application.

Thanks for your response.

Hey, it looks like I have the same issue.
I don't have any VPN Services installed, and I've already have done multiple clean reinstallations of Spotify. I've tried the Version from the Windows App Store and the Application from the Website.
Are there any other possible troubleshooting steps?
Thanks for your response.
Sorry for double message. Missed out to verify my Email-Adress and now both messages got sended

I am having the same problem. Tried reinstalling and restarting many times and it still didn't work. Does anyone have a solution?

Hey folks,

 

Thanks for your replies in this thread.

 

@Loox, from what you kindly mentioned, it looks like you're experiencing the inconvenience reported in this thread. This is being investigated there, so, we'd suggest you give a closer look at its status, in which you can find suggested steps to try. Rest assured this is being investigated.

 

On another note, we'd recommend adding your vote in the thumbs up icon and subscribe to the thread in the three dot menu, so you can stay up to date on any news on the matter.

 

@HariA90, in this case, we'd like to gather as much info as possible. Are you able to play your own playlists and your Liked song playlist? Is this happening on a Windows device? If yes, this is most likely the same scenario as the one described by @Loox. In that sense, we'd recommend also having a look at the mentioned thread.

 

If that scenario doesn't fit your inconvenience, it'd be really helpful if you share with us the make/model and OS of your device along with the Spotify version you have currently running.

 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Same. I already reinstalled Spotify and it still has the same issue. I can only listen to songs in my Library.

Save the album to your library (hit the heart button), you will then be able to play it. You can remove the save as well and still be able to play it.

alec29_0-1670609910083.png

 

same problem. performed clean reinstall 3 times. saving the album to library does not solve the issue 

Hey @johnkennis,

 

Thank you for your reply in this thread.

 

In this case, we'd like to gather as much info as possible. Would you mind letting us know if you experience this issue on mobile app or across different platforms? Sharing what troubleshooting you've tried so far would also be great as this'll help us avoid repeating steps. 

 

It's also worth mentioning that right now we have an Ongoing issue with playing tunes outside of Liked Songs or playlists on the desktop app. Go ahead and check this thread. If you're experiencing this, feel free to check out the status message and perform the troubleshooting mentioned in there to see if this will help you solve your problem.

 

We'll be on the lookout for your update.

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts