Help Wizard

Step 1


Friend activity stopped suddenly working, only shows 'find friends' option

Friend activity stopped suddenly working, only shows 'find friends' option


Country UK



Macbook Air late 2015

Operating System

MAC OS version 10.14.16 MOjave 


Friend activity working normally until suddenly only displayed find friends option 

Have tried the following:

Total Mac system update 


Delete and reinstall spotify x2  ( therefore running on latest version)

clearing the cache folder 

Logging in and out 

toggling the friend activity settings 

quitting it several times over 

connected my friends via facebook, as was previously using without facebook before 

following and unfollowing 

logging in on a seperate windows desktop  - still the same issue


have already voted for this topic on another chat thread to be investigated, can anyone suggest anything else/inform me if this has been a frequent issue and whether it will be resolved (how soon) is it an issue only affecting some users or some operating systems? 







5 Replies

I'm experiencing the same problem right now. I just updated Windows 10 to version 1909 and I'm using the version of Spotify.

Signing on and off or rebooting the system doesn't help.

when abouts did it stop working, mine was around 3 hours ago i think? hopefully could just be a glitch they are working on 

I have the same issue right now. I'am done anything I can do, but still I cannot see my friend's activity????

Hey there @camilawithonel, @lro, @camilawithonel and @elifka,


Thanks for letting us know about this! 


Currently there are issues with the Friend Activity feed. We've created an Ongoing Issue about this.


We advise you to go add your vote which will show that you too are experiencing this. You can vote by clicking on the +VOTE button. Feel free to subscribe to get relevant updates on the situation.


We hope this sheds light on the subject, stay tuned!

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Same Problem on a macbook pro 2012, already voted on the topic, hope you could fix this soon.

Suggested posts