Hiding activity: does not work

Reply

Hiding activity: does not work

skmeyer
Newbie

I would like to hide my activity on Spotify.  Specifically, I do not want people to see what I'm listening to, even when they are not following me. 

 

I went to preferences and unchecked:

"share my activity and what I listen to with my followers on Spotify"

"share my activity and what I listen to on Facebook"

"automatically make new playlists public"

"make my top tracks playlist public"

"show the top artists I have been listening to".

 

My husband has a separate Spotify subscription and he is not following me.  When he logs in to his account on his iMac, and goes to the follow section, there I am with the top artists I've been listening to, under my name.

 

Is this a bug?  I cannot find any other options to uncheck.  Very annoying and this problem has persisted through several updates.


Thanks for your advice.

2 Replies

Re: Hiding activity: does not work

MichaelJerzak
Community Legend
Have you tried using "Private Session"
Michael. A Spotify Knight in Shining Armor.
I AM NOT A SPOTIFY STAFF MEMBER| I'm a Spotify Community Legend
Was this information helpful to you? Give me kudos or accept as solution, if so!
Highlighted

Re: Hiding activity: does not work

Peter__
Community Legend

If your husband had viewed your profile recently then his client will be showing old cached data rather than what is actually being shown publically by the Spotify server. 

 

If your Spotify username is "skmeyer" then I can confirm you have no artists, playlists or activity showing on your public profile. 

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

SUGGESTED POSTS