How to prevent local files from playing?

Reply

How to prevent local files from playing?

diotapio
Casual Listener

I've got tons of MP3s on my Mac, many of them live. It happens very often so that when I play an album from Spotify, it suddenly plays one of the tracks from the local hard drive instead of the one on the album. I prefer to use iTunes to play the local MP3 files.

 

How I can force Spotify play only music from online and not from my local drive? 

 

3 Replies

Re: How to prevent local files from playing?

Rock Star 16
Rock Star 16

Hey @diotapio, welcome to the Community.

Hope you're doing great!

 

To prevent Spotify accessing the local files you have just head to it's Settings under Local Files section toggle the switch to off. You should be good to go!

Let me know how it goes :)

 

 

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: How to prevent local files from playing?

diotapio
Casual Listener

In the settings I've turned off both options (Downloads and My Music) under the "Local files"/"Show songs from" section. It has no effect whatsoever on this behavior.

Highlighted

Re: How to prevent local files from playing?

Rock Star 16
Rock Star 16

Hey @diotapio,

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstall of the app. Just follow these steps.

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

LoxerRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
SUGGESTED POSTS