Announcements

Lag on Apple Silicon

Lag on Apple Silicon

Constantine314

Plan

Premium

 

Device

MacBook Air (2022, M2)

 

Operating System

macOS Monterey 12.5

 

My Question or Issue:

 

The Spotify interface and animations are often very choppy on my Apple Silicon mac with hardware acceleration on, and scrolling feels choppy and skippy. Many other mac users are also experiencing this issue. Considering the app runs perfectly on my iOS devices using much less powerful apple silicon I expected to have a similarly smooth experience on mac. Additionally, checking activity monitor reveals that performance is not being bottlenecked by system hardware as the app is only using about 10% of the available CPU and GPU at a maximum.

 

Reply
3 Replies

Loxer

Hey @, welcome to the Community.

Hope you're doing great!

 

Have you tried disabling Hardware Acceleration? You can do that by clicking on the Menu Bar > Spotify > Hardware Acceleration.

 

Let me know how it goes 🙂

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Constantine314

Yes, disabling hardware acceleration does seem to improve the issue. Still feels strange considering HA is enabled by default. Why should a feature be in the default settings if the effort isn't being made to optimize it properly? Anyways thanks for the response. I was considering disabling HA before but since it was enabled by default I was unsure whether that would be harmful in any way. Is there anything I should be worried about with disabling HA?

Loxer

Hey @Constantine314,

 

Nothing to worry about turning HA off. I've had issues with different apps and have turned HA off (like Chrome and Edge).

You could try again in another update and see if it still causes issues for you.

 

I'm assuming you have the Apple Silicon edition installed and not the Intel one. Check by going into Menu Bar > Spotify > About Spotify.

 

You could also try turning off Local Files if you are not using that feature. Go to Spotify Settings and toggle Show local files to off.

 

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Suggested posts

Env: prod