MacBook Pro Big Sur OS. Auto open at startup.

Reply

MacBook Pro Big Sur OS. Auto open at startup.

Rock5219
Visitor

How do I stop Spotify from opening automatically on my desktop device?

3 Replies

Eni
Moderator
Moderator

Hey there @WildElf

 

Thanks for reaching out about this. 

 

Could you let us know if the "Open Spotify automatically after you log into the computer" option in the app settings toggles back to yes automatically? Or if you've already disabled that option and despite that Spotify keeps opening when you log in to the PC.

 

Additionally, it's also well worth running a clean reinstall to check if that makes the difference. This process is more thorough than a normal one. 

 

Keep us posted. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Billy-J
Rock Star 24
Rock Star 24

Hey @Rock5219, thanks for reaching out to the Community!

 

There's an option to turn this off. You'd need to go to the Spotify app on the Mac > Dropdown menu > Advanced settings > Disable Spotify auto-start. Under the Startup and Window Behavior heading, change the Open Spotify automatically after you log into the computer dropdown to No.

 

Hope this helps! Let me know how it goes.

Billy-JRock Star 24
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

WildElf
Casual Listener

This does not work. It's not limited to Big Sur (11.4). It's broken on Mojave as well (10.14). It should work. It works on Windows. I've rebooted my Mac (10.14.6 (18G9216)) three times, and each time Spotify (1.1.60.672.g6ad9c215-a) launches at startup. Each time I go to Preferences > Advanced Settings and "Open Spotify automatically..." is set to "No" already.

 

I also checked in System Preferences > Users & Groups, and Spotify is not among the Login Items, which could override the application settings.

 

There is a clear problem with the setting that is not macOS specific.

SUGGESTED POSTS