Announcements

Next song starts somewhere in the middle

Solved!

Next song starts somewhere in the middle

douira

On some playlists (the last one this happened on was "Deep House Relax") when one song ends it starts the next some somewhere in the middle after an unusually long crossfade. 

After some investigation, it seems this is a feature that some playlists have. This behavior should have a setting to disable it as it's quite disruptive to the listening experience in my opinion. (and apparently, also everybody else who joined in on this thread) 

Important: This is not the regular crossfade! This starts songs literally a minute in, not just 12 seconds like the normal crossfade. This behavior seems to appear even with crossfade turned off!

 

 

Family Premium

Germany

macOS 10.13.6 (latest at the time) 

Reply
51 Replies

douira

(sorry for accidentally toggling the solution)

This feature is so badly designed that in many instances, this "feature" looks like a bug. Also, Spotify might notice this problem faster if it's marked/reported as a bug. However, we are still striving for a solution that adds an option to turn it on and off.

kubasvoboda

@axl_magnum I spoke with my friend who actually liked the feature as you did - as kind of a artificial DJ in playlists. For him it worked pretty well on some playlists/transitions.

 

So I am not for nuking it straight away, but nevertheless the option should be present for switching it off and on - as the idea for it is described.

axl_magnum

Yes, as I stated yesterday, I think the feature is achieved for some playlist (specifically for the techno ones) but not for all of them, causing the complaint of some users. It would be great having an on/off playlist, as a multigenre listener I also want to be capable of turning it off when I listen to some Lofi (e.g. Jazz Vibes playlist).

tyvahan

Posting another workaround aside from the copying the playlist to make your own version of it:

Adding the playlist to your queue will also disable the autofade. The disadvantage of this method being you can't shuffle it.

Hopefully they give us the option to shut this feature off soon!

SethXRG

This sort of under the rug "let's test this and not tell anyone" is why I only get Spotify when it's 1$ or heavily discounted. I'll never support this business model of forcing change on the user without some warning. 

 

People actually like listening to full tracks without a jarring switch. Isn't that crazy?

apurba

Go to settings, and then advanced settings and then automix and disable it. Problem solved! 

apurba
Go to settings, and then advanced settings, and then automix and disable it. Problem solved! 
Marked as solution

Katerina

Hey there everyone,

 

Thanks for posting about this here in the Community!

 

Some playlists, like Deep House Relax on Spotify that @douira mentions, have beat-matched transitions even when Crossfade or Shuffle are toggled off.

 

However, as @apurba mentioned, if you'd like to disable these transitions you can toggle Automix off from the app's Settings.

 

Hope this helps! Don't hesitate to give us a shout if there's anything else we can lend a hand with.

 

Have a lovely day 🙂

KaterinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

skuruganti45

This is not helpful at all, for over 2 years now I have had my most played playlists, chill tracks and brain food just start every next song as some random spot and there is NO WAY to turn it off...

 

seriously if this isn't fixed soon I am switching to Apple Music, absolutely ridiculous.

douira

There is an option to turn this off now, it's just an issue of finding it. Here are three screenshots on how to find the setting on macOS. The setting will be similarly placed on Windows.

Screenshot 2020-03-25 at 12.09.03.png

Screenshot 2020-03-25 at 12.09.20.png

 

Screenshot 2020-03-25 at 12.09.29.png

  

skuruganti45

I have no such option:

 

skuruganti45_0-1585136404122.png

 

douira

Have you updated to the latest version of Spotify? The current latest version is 1.1.28.721.g5b5ee660 on macOS. Which OS are you using? 

Suggested posts

Env: prod