No internet connection (error 4)/Local files not loading/"Error in template application" MAC

Solved!
Reply

No internet connection (error 4)/Local files not loading/"Error in template application" MAC

izzo0o0o
Casual Listener

I have looked all thought the posts but still cannot find a solution to my Spotify problems.

 

When I log in, very little loads properly, my local files come up but won't play. No playlists are coming up and an error bar at the top says "No internet connection detected Spotify will automatically try to reconnect when it detects an internet connection. (error code 4)."
In my Library/Inbox/Play Queue/Devices at the top it says: "error in template application - Parse error error in views/Library(or Inbox/play queue etc)._header.xml" Then i scroll down and it says "Description:  problem happened during execution of the request. please review the stack trace for more information about the error and where it originates in the code" (see the screen shot).

 

This has been going on for a good month (i've been busy so just hoped it would fix itself), over several wifi connections (home, uni, parents house). My housemate also has spotify and it is working fine on her computer. Everything else is working fine on my computer, internet is nice and fast. So I have no idea what is the problem. I've tried some things:

 

1. First I restarted my wifi - no change.

2. Then I restarted Spotify - no change.

3. I also restarted my router - no change.

4. then I checked the firewall - has been off the whole time.

5. then I attempted to uninstall Spotify. The "~/Library/Caches/com.spotify.Client
~/Library/Application Support/Spotify" folders that I need to delete are nowhere to be found. I searched through the Caches folder and App support folder and then my whole computer and they are nowhere. So i preceded to delete the Application itself and reinstalled.
But then once reinstalled, the same issues came up.

 

In the preference box it says the Cache is located in the Cache folder but when I click Browse nothing happens. 

 

I am operating on a MacBook Pro OS X. 

 

I would tell you what spotify version I'm using but it came up with a message saying "Error in template application etc" again.

 

Internet provider is iiNet and I'm in Perth, Austalia.

My username is (according to the top right hand box) ***(edited for security)...? Hah or izzy.***@*** (edited for security).

 

Heeeellpp

 

Screen Shot 2013-07-01 at 11.31.56AM.jpg
2 ACCEPTED SOLUTIONS
Solution!

1213646253
Newbie

PROBLEM FIXED , JUST LOG OUT AND LOGIN WITH FACEBOOK ^_-

View solution in original post

Solution!

brettnordmann
Newbie

I had the same problem and found that one of my devices (Iphone) was still signed on to Spotify.  When I logged out on my phone I tried right away to log in on my Mac and it went right through.  No problems anymore.  That might explain why some other people had no problems when they logged in with another users information?  They might have a device still logged in and it prevents them from logging in again with another device.


 

View solution in original post

48 Replies
SUGGESTED POSTS