Playlists won't load and songs won't play

Solved!
Reply

Playlists won't load and songs won't play

Ravenny
Visitor

Plan

Premium

Country

Netherlands

Device

MacBook Pro 15 inch 2013

Operating System

MacOs Mojave

 

Since a few days some songs I have added to certain playlists on my phone wouldn't show up in my playlists on my MacBook. Today I wanted to fix this so I reinstalled spotify - deleted every file, even in library - hoping this would fix it. However this made spotify unusable as now all my playlists are empty and I am only able to play songs using the "Browse" section. 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Playlists won't load and songs won't play

Rock Star 14
Rock Star 14

Hey there @Ravenny !

 

This a known bug with the desktop app and Spotify is investigating the issue. There is a workaround which seems to be working for some users. Can you try the following steps:

  1. Open Finder and, in Finder’s menu bar, select Go > Go to Folder. In the box, type the following location: /private/etc/hosts and press return.
  2. A new Finder window will open and your Mac’s hosts file will be selected. Click and drag it out of the Finder window and drop it on your desktop. 
  3. To open it, simply double-click and it will display the file’s contents in TextEdit.
  4. Check for any entries with Spotify in the address.
  5. If you do find any lines with Spotify, remove them.
  6. Save your changes and restart Spotify.

Hope that solves the issue! Let me know if you have further questions. There is also an open issue about this here where you can track it and vote for it so it catches more attention. I hope this will get fixed on Spotify's end soon.

 

Have a nice day :)

MantisentilRock Star 14
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
4 Replies
Solution!

Re: Playlists won't load and songs won't play

Rock Star 14
Rock Star 14

Hey there @Ravenny !

 

This a known bug with the desktop app and Spotify is investigating the issue. There is a workaround which seems to be working for some users. Can you try the following steps:

  1. Open Finder and, in Finder’s menu bar, select Go > Go to Folder. In the box, type the following location: /private/etc/hosts and press return.
  2. A new Finder window will open and your Mac’s hosts file will be selected. Click and drag it out of the Finder window and drop it on your desktop. 
  3. To open it, simply double-click and it will display the file’s contents in TextEdit.
  4. Check for any entries with Spotify in the address.
  5. If you do find any lines with Spotify, remove them.
  6. Save your changes and restart Spotify.

Hope that solves the issue! Let me know if you have further questions. There is also an open issue about this here where you can track it and vote for it so it catches more attention. I hope this will get fixed on Spotify's end soon.

 

Have a nice day :)

MantisentilRock Star 14
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Playlists won't load and songs won't play

j_hammond17
Casual Listener

Hi, I tried the various solutions listed on this forum and I am still having the problem. Ive tried clearing spotify from the cache list reinstalling rebooting then installing, signing out and back in several times with unfortunately no success. Can someone pls help me!! Just want to be able to listen to songs on my laptop :/ Thanks in advance

-James H

Re: Playlists won't load and songs won't play

j_hammond17
Casual Listener

Nevermind had to replace the file, close spotify, and then reopen it. Thanks tho!! :)

Highlighted

Re: Playlists won't load and songs won't play

johnmbeck
Newbie

Spent hours looking for a solution to the issue on my iMac. Wasted time following instructions to clear cache & reinstall. The windows desktop version appears to have a workable solution (editing files), but nothing, nothing, I repeat, nothing has fixed this problem for me and it is hugely annoying.

SUGGESTED POSTS