Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Re: Spotify app not playing on Sonoma 14.1

Solved!

Re: Spotify app not playing on Sonoma 14.1

I've also run into this issue. The web version of the app works fine.  The desktop app appears to work but the play button etc buttons are always greyed out. I've tried restarting and reinstalling. The desktop app worked fine a week ago.

Spotify for macOS (Apple Silicon)
1.2.26.1187.g36b715a1

macOS Sonoma 14.2

Reply
40 Replies

Plan

Premium

Country

UK

Device

Mac mini M1 2020

Operating System

MacOs 14.2.1 (Sonoma)

 

My Question or Issue

The usually stable Mac client has repeatedly started crashing on startup - I've had to resort to listening on my iPad instead. I've found this resolves on reboot, but after a while starts crashing again (only on startup).

Have removed and re-installed, cleared cache etc. Crash report attached.

I cannot play any songs using the Mac desktop app on MacOS Sonoma 14.2. 

 

Steps to reproduce: 

- Open the desktop app

- Click on any song to play

 

Expected result

- The song starts playing within a few seconds

 

Actual result

- The song does not play. Additionally the media controls and seek bar remain inactive. No time remaining is shown. 

 

donturner_0-1705919675362.png

 

Additionally I cannot download any songs. The download indicator just sits at 0%. I can browse all songs, just cannot play them. 

 

Things I have tried

- Toggling WiFi

- Toggling offline mode 

- Logging out, then back in again

- Rebooting my machine. This had no effect.

- Uninstalling and reinstalling the app. After running the newly installed app the songs do play, but then after an indeterminate amount of time (typically 1-2 days) the songs stop playing. 

 

I have a reliable 80mbps internet connection and have no problem playing song using Spotify Web or the Spotify Android app on my phone (Pixel 7 Pro) which is connected to the same WiFi network.  

 

Plan

Premium

Country

UK

Device

Macbook M1 Pro 

Operating System

MacOS Sonoma 14.2.1 (23C71)

 

To Spotify admins: Why has my topic been merged with this solved one? The issue isn't solved for me or for a few other people. It looks like there's a bug in the Spotify MacOS app. Please move it back to its own topic, or mark this thread as unsolved.    

Hey again folks, 

 

Thanks for the provided info so far. So we can investigate even further, could you send us the following details if you haven't already:

 

  • The exact Spotify-version you're running
  • What troubleshooting steps you have tried and did you notice if any of them made any difference
  • A screenshot or a video recording showing how the app behaves from your end (you can attach them to your next response by using the Insert Image/Insert Video option in the post editor)

Cheers 🙂

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I've been experiencing the same issue that many in this thread have described, for the past 1-2 weeks--songs are greyed out, and when I try to play any the app says I'm in offline mode. The web player works fine for me.

 

Spotify version: 

Spotify for macOS (Apple Silicon) 1.2.29.605.g66a43ceb

 

MacOS: Sonoma 14.2.1 (23C71)

 

Troubleshooting steps I've tried

- Toggling WiFi on my laptop

- Toggling offline mode

- Restarting the app

- Reinstalling the app. This worked for a bit, then less than a day later songs stopped playing again

- Deleting prefs/user as suggested in this thread.

I have the same problem!

Have tried different networks and reinstalling the app.

 

I also tried logging in to a friends account on my Mac, and THAN IT WORKS?! 

 

So it seems to be a problem with the Spotify account, and not anything with the Mac?

 

Please help me find a solution!

Here's my Spotify version:

 

Spotify for macOS (Apple Silicon)
1.2.29.605.g66a43ceb

 

Sounds like a caching issue to me. 

Ivelina - Please could you mark this thread as unsolved. The problem remains for at least 3 people. 

Hey folks,

 

Thanks for your replies.

 

@vilde22, thanks for letting us know what worked for you. To make sure the issue is indeed in your account, we'd recommend creating a new one using a different email address and using it for a couple of days.

 

@tefb and @donturner, can you try this as well?

 

Cheers,

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

When I try to log into a different account, the app shows me this:

Screenshot 2024-01-26 at 12.22.05 PM.png

Hey @tefb,

 

Thanks for your reply

 

That's odd, can you try changing the proxy settings from the app's settings and see if that helps?

 

Cheers,

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Sadly, the bug has returned. As before, the macOS Spotify app starts and looks like it's ready to go, but it will not actually play. 

 

I've tried various re-install etc strategies and I've just upgraded to Sonoma 14.3 but the app still doesn't play. This continues to be really frustrating, as the app doesn't provide any feedback at all about why pressing "play" doesn't play.

I changed the proxy setting to 'No proxy' and restarted the app--it worked for a little bit (<1hr) until the problem came back.

Thanks for the cooperation and for all the provided details, folks!

 

We've reported the performance issues to the tech team and they'll be investigating this further. Hopefully, we'll have an update soon. 

 

In the meantime, you can keep an eye on this thread and let us know if you have any questions.

 

Cheers 🙂

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

The macOS desktop Spotify app is working for me again. Per this (very very detailed) analysis, it appears that Spotify has fixed a problem by working around a macOS bug or quirk: https://rbf.dev/blog/2024/01/how-apple-accidentally-broke-my-spotify/

 

Hey folks,

 

Thank you for your messages.

 

@hansmuller we appreciate your confirmation. The app has been updated to version 1.2.30 that fixes some of the reported issues. So we'd recommend updating your app to the latest version. If the issue persists, we'd also recommend performing a clean reinstall of the app as cache may affect its proper behavior. 

 

Let us know how it goes.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

What an incredible investigation. Thanks for sharing. 

 

Can confirm Spotify is working correctly for me as well now. Not sure if it was auto updated or whether the recent MacOS update fixed the underlying issue but everything works as normal now. 

Spotify is no longer working after updating to Sonoma 14.3.1 

 

When I press play it shows the sound icon as if it is playing but the song is not advancing at all, so it's not an audio output issue. It literally does not play the song itself. I can move the slider to different times in the song, but it doesn't move. Just stays stuck no matter how many times I hit play and pause.

 

What's even weirder is that if I connect to my roku it plays fine on my tv. So network and connection is no problem. All other audio programs play fine on my computer itself. Only spotify won't play.

 

Have cleared caches and application support files and reinstalled twice. No change. 

 

 

 

 

Hello, 

Are there other ways to access Settings? My screen stays like this. Running on Sonoma 14.4.

Thanks!

Screenshot 2024-02-15 at 9.26.52 PM.png

thank you! working for me now

Plan Premium

Country Germany

Device Macbook Air 2019

Operating System: MacOS 14.1.1 (23B81)
Spotify for macOS (Intel) 1.2.31.1205.g4d59ad7c

Desktop app refuses to play songs. Web player works fine. Weirdly enough, I can use the desktop app as the interface for the web player - if I close the web player, playback is over.

Cleared cached, logged out, reinstalled, crossfade on and off, offline mode on and off, hardware acceleration on and off, different networks. Nothing works for me. Memory is more than enough, and so is storage. Could anyone please help me?

Picture shows what happens when I try to play a song: nothing.

Screenshot 2024-02-23 at 4.49.33 PM.png

Suggested posts