Announcements

SPOTIFY NOT WORKING AFTER UPDATING TO macOS Catalina 10.15.6

Solved!

SPOTIFY NOT WORKING AFTER UPDATING TO macOS Catalina 10.15.6

kiyopke

Plan

Premium

Country

Indonesia

Device

(MacBook Air 2017)

Operating System

(macOS Catalina 10.15.6)

 

My Question or Issue

I just finished installing Mac OS Catalina, and each time I try to open Spotify, the icon jumps like normal as if it’s about to open, and then it just doesn’t open. I’ve uninstalled and reinstalled Spotify several times as well as clearing the cache, but the problem still persists. Is there any way to fix it? 

ezgif.com-crop-2.gif
Reply

Accepted Solutions
Marked as solution

kiyopke

Try these steps guys, it worked for me.

- Click Spotify in the menu bar, then Quit Spotify.

- Open Finder then click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn’t visible).

- Open Caches and delete all folders related to Spotify.

- Click the back arrow.

- Open Application Support and delete the Spotify folder.

- Go to http://spotify.com/download and reinstall Spotify.

View solution in original post

16 Replies

diboshbaruah
I am also facing this same issue on my MacBook since today. It is running fine on my iPhone but unable to open the Spotify app on my MacBook

patalbwil

Having same issue.  Did not begin until after upgrading to 10.15.6. Works on iPhone but not Macbook. An uninstall/reinstall temporarily fixed it for 1-2 days.

Elena

Hey there folks,

 

Thanks for reaching out about this!

 

We are currently looking into this issue and would need some more information. We'd really appreciate if you could tell us the following:

  • Make and model of your device.
  • Exact version of your iOS.
  • Exact version of Spotify.
  • Does this happen in Offline mode?
  • Does this happen when you're connected to a different network?

We'll be on the lookout for your replies. If more questions come up, don't hesitate to reach out again.

 

Have a great day!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

kiyopke

Try these steps guys, it worked for me.

- Click Spotify in the menu bar, then Quit Spotify.

- Open Finder then click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn’t visible).

- Open Caches and delete all folders related to Spotify.

- Click the back arrow.

- Open Application Support and delete the Spotify folder.

- Go to http://spotify.com/download and reinstall Spotify.

matteolspace-3

The solution purposed it did not work for me.

What worked instead is this

kiyopke

I see. I’ve also tried that before but the problem still persisted, instead I tried what I suggested in the post and it worked fine. 

Anyway it’s a good thing we can finally enjoy Spotify on MacBook again 😊

elrealblancos

Hi Elena,

 

In the past week, I have encountered problems exactly the same with this thread.

When I uninstalled it, I shutdown, opened again, installed again and it worked.

But somehow after several songs, the app doesn't work and got hang. I managed to force close the app and restart again, but it stuck again.

 

Any idea how to overcome this problem?

 

MacOS Catalina 10.15.6 on MacBook Air 2019.

manahmed1

Connecting the Macbook to the Power cord allowed Spotify to start. It seems like OS X is disabling hardware acceleration on Battery power. This was not allowing Spotify with Hardware Acceleration enabled to start.

 

Hope this helps.

sharonsgh

Hi, I'm having the same problem. I tried this but still can't re-install the app. Is there anything else that can be done?

Mihail

Hey @sharonsgh,

 

Thanks for searching for the answer you need here.

 

Just to confirm, have you tried a clean reinstall of the Spotify app on your device? We recommend the steps in that guide, as they’re very thorough and make sure no damaged leftover files remain. Make sure to also restart your device in the process as some users report that when they didn't the issue persists. If you're having issues with the process, could you explain in greater detail where exactly you get stuck?

 

If any error messages appear, we'd appreciate it if you include of screenshots of them in your next response. You can use the Insert Photo option in the Post Editor, just make sure to hide any private/ sensitive info.

 

@manahmed1 mentions that having the desktop plugged in helped the start the app. Does that make a difference in your case? If it does, once you start the app, it's a good idea to disable Hardware Acceleration from the Setting menu.

 

Keep us posted. We’ll keep an eye out for your reply.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

ademaxazi

This occurred to me after updating to macOS Big Sur version 11.2.1.

Make and model: Macbook Pro 13-inch, 2020

Spotify version is that latest that is of 2021

Yes it occurs in offline mode

it occurs regardless of network connection

Screen Shot 2021-02-11 at 12.12.01 PM.png

Eni

Hey there @ademaxazi

 

Thanks for reaching out about this. 

 

Would you mind restarting your PC in Safe mode and run a clean reinstall of the app this way? 

 

Also, we suggest that you restart your router as well before trying it again. 

 

Let us know how it goes 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

ademaxazi

 thanks for the help, it now works!

Eni

Hi @ademaxazi,

 

Fantastic news! Give us a shout if it starts misbehaving again; we're always here to help. 

 

Have a great day!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

BluCreator

Thanks for these instructions!! Here's a simple script to clear them since the issue happens so often for me. You type your password once to authenticate clearing the cache.

Suggested posts

Env: prod