Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify Pausing with new speakers / dac

Spotify Pausing with new speakers / dac

Version of spotify:

Macbook Pro - late 2012


Hey Spotify Community,


I just purchased a set of AudioEngine A5+ speakers and a D1 DAC and started encountering a pretty random issue with Spotify. As I was playing songs via spotify, around the 1.5 minute mark,  music would stop coming out of the system for 2-3 seconds, then play for 10 seconds, then pause agian for 2-3 seconds (and repeat). This sounds to me like a buffering issue (the music was "saved to be available offline"). I'd never encountered this issue before. My D1 DAC is conncted to my mac via USB cable. Additionally, this issue is not occuring with iTunes.


I've searched the forums and couldn't find anything similar.


Any one have any ideas?


Thank you!



8 Replies



I have a similar issue. I use a HRT Music streamer II+ DAC. Random pauses and dropouts, in offline and online mode.

I contacted Spotify, and they suggested to do the following:


1. Click Spotify in the menu bar then Quit Spotify.
2. Open Finder then click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn’t visible).
3. Open Caches and delete the com.spotify.Client folder.
4. Click the back arrow.
5. Open Application Support and delete the Spotify folder.
6. Reinstall Spotify!


This helped for 5 days, but now the problem is back. Getting the impression that Spotify doesn't go well with DAC's...

I'm so glad to find this thread. I thought I was going crazy!


I've been using Spotify with a DAC on OSX (Mountain Lion, Maverick, now Yosemite) for over a year now. I've never had a problem. In the past week the music has been dropping out in the middle of songs. At first I thought I had a bad internet connection, but then I noticed:

- Offline Spotify songs had the same problem

- Switching to the computer's headphone jack fixed the problem (i.e. not using the DAC).

- Switching to ITunes Radio (while using the DAC) worked fine.


I had no idea that DAC output could be application specific. Anyway it's horrible. I've followed your suggestion, and it's better now, thanks!


 (Oh, I also downgraded to 0.9.15 and force Spotify not to auto-upgrade)

I am having the very same issue. Music pauses and resumes at random when using my DAC (FiiO E7 + FiiO E9), the internal sound card does not have this issue.


The music seems to resume when I:

- Cmd-Tab to Spotify (focus Spotify instead of Chrome)

- Play a different sound (like the notification sounds in the system perferences)


It seems to be happening with the latest version of Spotify. Is there any debug mode I can use?


EDIT: Ok, some things that I tried:
Use Airfoil to stream the music from spotify to the USB Dac (just stream to the computer). For some reason, this works, but Airfoil introduces a 2 second delay... There seems to be something wrong with the way Spotify sends audio to audio devices connected to the Mac. Please fix this.

For reference, my problem was with the DAC (FiiO E7 + FiiO E9) too.

I too have had the same problem. Ramdom spikes on an Audioengine D3 DAC, hiccups on a Motu Microbook and also but not as frequent on a VMODA Vamp Versa. Someone at Spotify should investigate this issue as us audiophiles who prefer to use Spotify are having issues. Maybe you can address this and get back to us. Thank you, Victor 

Same issue here. Only seems to affect some of my DACs (ie. Grace Design m9xx). Others work fine (ie. Dragonfly 1.2). Pretty infuriating though. Thinking a move to Tidal or Apple Music is not far away.

This is driving me nuts. Audioengine D1 DAC using the Spotify app for OSX El Capitan. Same issues as the above. I tried moving the DAC's USB plug from my Thunderbolt display directly into my Macbook, and though it helped for a day, the problem soon returned.

The same for me and Fubar IV Plus on El Capitan.

Suggested posts