Spotify app won't start and keeps copying itself every 4 seconds until I delete the "original"

Reply

Spotify app won't start and keeps copying itself every 4 seconds until I delete the "original"

guillerming
Casual Listener

Plan

Premium

Country

Spain

 

Device

MacBook Pro 2017

Operating System

macOs Big Sur

 

My Question or Issue

I have several users on my laptop. I was working on one user listening to my music, finished my tasks, logged out (completely out) from that user and entered into another. Spotify automatically tried to load, I don't have it configured like so, but I didn't bother about that too much, until I noticed it started looping, appearing and disappearing from my dock, while listening to my computer fans running faster and louder by seconds.

I tried to force-stop the app, but it kept looping so I totally deleted it using AppCleaner, then went to the website and download the installer again. Then executed the fresh installation, and same result.

 

I'm attaching a screenshot where you can see my paper bin, you can see it copies itself every 3-4 seconds.

Captura de pantalla 2021-01-25 a las 18.41.00.png
3 Replies

Ivan
Spotify Legend

Hey @guillerming

 

Help’s here!
 

If the troubleshooting you've tried so far didn't help another thing you can try is running a clean reinstall of Spotify on your MacBook. This will remove corrupted data from previous installations that could be causing the issue. 

 

In case you see no difference after the clean reinstall, check your hosts file for entries that need to be deleted. Follow the steps described here on how you can do that. 

 

Let us know how you get on! We'll be here in case you need any further help with this. 

guillerming
Casual Listener

Hi Ivan, sorry for replying that late.

Yes, it happened again. Back in the day, a fresh installation finally solved the issue. Apparently not anymore.

 

I've repeated the process: Deleted all Spotify files using AppCleaner. Removed any trace of "spotify" under "library". Searched for entries on hosts file (there were no entries for spotify).

Nothing resulted. It keeps looping.

Is there anything else I can do to troubleshoot this and help you find out the issue? I have tech background as a web developer so don't mind getting too "techie" 🙂

Thanks.

Jeremy
Moderator
Moderator

Hi there @guillerming,

 

Thank you for your reply and confirmation.

 

Can you perform the clean reinstall again but this time in Safe mode?
 

Keep us posted 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂
SUGGESTED POSTS