Announcements

Help Wizard

Step 1

NEXT STEP

Spotify becomes unresponsive to headset controls after a period of time

Spotify becomes unresponsive to headset controls after a period of time

Brief description of the issue:

I have a Sony WH-H900N wireless bluetooth headset, that I connect with my 13" MacBook Pro 2018. I leave it connected all day long, sometimes I have meetings where I use my headset for Google Meet sessions, sometimes I just leave it lying around.

 

However, when I come back and I do the double-tap to resume playback, Spotify doesn't respond. Sometimes when I open the application, the playback resumes automatically, but most of the times, I have to click the play button in order to play music again.

 

The touchbar also hides the ehm.. play-icon thing after a while of inactivity. It seems to be around this time that the headset controls stop working. It's almost like Spotify goes (or is being put) into a sort of 'hibernation mode'.

 

Just for clarification, the headset controls work perfectly fine when Spotify is pulled from the 'hibernation mode'

 

Steps to reproduce the issue:

  1. Have a headset connected (I'm not sure if this problem exists for wired AND wireless headsets, but I own a Sony WH-H900N which is wireless)
  2. Open Spotify and play a little bit of music
  3. Pause the music and go do other stuff
  4. Try to resume playback without focussing Spotify after like 30 minutes (to be safe, I don't know exactly how long it takes)

What steps you’ve tried already:

I've tried reinstalling Spotify, and I reconnected my headset multiple times. I looked for a 'stand-by mode' or 'sleep mode' in Spotify and in my Macbook's preferences, but I couldn't find anything.

 

 

Your device and operating system (e.g. MacBook Air, 10.10 OSX)

MacBook Pro 13" with Touchbar 2018, macOS Mojave 10.14.2

 

Type of Spotify account you have (Free/ Premium):

Premium/Family (not sure what matters more)

 

The app version of Spotify you’re using:

1.0.96.181

Reply
2 Replies

This is definetely an issue on the headset, try looking at sony's forums and see if you can find something on it. Also try factory resetting your headset if you haven't already.

Disagree I have Beats headphones and have a similar issue. When paused often have to close and restart the application to get it working again.

Suggested posts