Spotify desktop app starts at login even though disabled

Solved!
Reply

Spotify desktop app starts at login even though disabled

kentonvannatten
Music Fan

US

Device

iMac, Mojave

 

When I start up my computer and log in, Spotify automatically launches.

I have "Open Spotify automatically after you log into the computer" set to "No", yet it is still doing it. I read a solution on the Windows forum that I should disable the web player as well, but I don't see that option (see image). 

 

Screenshot 2019-05-16 21.00.23.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Peter
Spotify Legend

Hey @kentonvannatten.

 

Hope you don't mind me jumping in here 🙂

 

Have you tried the steps in this Apple Support article already? It should have the answer you're looking for.

 

Keep us posted and let us know how it goes! We'll be here in case you need further help with this.

View solution in original post

6 Replies

rouward
Music Fan

Disable Spotify on Startup Tab on Task Manager, if you're on Windows 7, search "msconfig" instead.

Edit: Oh you're on Mac, I thought it's for Windows sorry for that. Just search something related to Startup on your Mac and disable there. I have literally no idea how to operate Mac.

aefasdfasdflol
Casual Listener

Please go to system preferences -> Users and groups-> Account- > login items and remove the app from the list. 

Please accept it as answer if it works! 

🙂  @kentonvannatten

kentonvannatten
Music Fan

Thanks, but it's not in my login items list. 

 

I think what causes it to happen is that if I've been listening to Spotify and then I shutdown/reboot the computer, it re-launches apps that were open during the last session. The last few times I've booted the computer Spotify hasn't launched, but then that is likely because I didn't have Spotify open before the previous shutdown. 

Solution!

Peter
Spotify Legend

Hey @kentonvannatten.

 

Hope you don't mind me jumping in here 🙂

 

Have you tried the steps in this Apple Support article already? It should have the answer you're looking for.

 

Keep us posted and let us know how it goes! We'll be here in case you need further help with this.

View solution in original post

CriticalMass
Casual Listener

Same here. Nothing in Startup Items, No scripts in ~/Library/Launchagents or ~/Library/Launchdaemons.

Equally none in the systems Library folders either. So all points where you can enable or disable automatic start of apps are empty.

The front-end is started and in my system I also see helper daemon threads running.

 

The suggestion by @Peter was very clever and to the point (check at shutdown whether you have "open windows at restart" checked). But that too is not applicable in my system. I don't have any user apps set to autostart in any way.

I want to know where spotify stores its autostart scripts, and how I can stop this from happening permanently.

 

I hate it when apps screw around with customer's system integrity.

CriticalMass
Casual Listener

Here's the answer that works for me:

Locate the Application folder

Select the spotify app, and right-click on the icon

In the popup menu, select "Show package contents"

The contents is presented in a finder window. Now navigate to the Library folder

What hey, you will see a "Loginitems" folder. Open that folder.

There you will find a file named "StartupHelper"

 

The following is changing the file name. Don't delete that file. Renaming it is fine. Or better said, it works for me.

I renamed it to "OrigNameIs_Startuphelper"

Disclaimer: If my advise breaks things, Then you'll probably have to reinstall. The choice to change the filename on your machine is yours, not mine.

 

Other than that, it works quite nicely on my machine.

SUGGESTED POSTS