Spotify on OS X 10.6.8


Spotify on OS X 10.6.8

Casual Listener

I have an old MacBook 1,1 that I want to use only to stream music from Spotify.

The latest OS X he can run is 10.6.8, the actual Spotify release wants OS X 10.10, the web player is not available in the latest Opera (25.0.1614.71) and Firefox (48.0.2), Edge and Chrome not available.


As suggested i downloaded Spotify 0.8.5 and it started well but it says "Connection lost. Reconnecting.. (error code: 101)" clicking on the error bring to a 404 page.

But the computer is online and also the ADV banner is shown.


Any thought to not trash the old-but-gold mac?


Schermata 2019-02-28 a 00.23.26.png
5 Replies

Re: Spotify on OS X 10.6.8

Spotify Legend

Hey @taranteirno.


Thanks for getting in touch!


We're sorry to say but you'll need 10.10 to fully make use of Spotify. You can always try a reinstallation but we can't guarantee it will work.


Perhaps you can find a work-around by installing a newer version of MacOS on your computer, or a newer version of a supported web-browser for the WebPlayer.


Hope that will work. Let us know if you have further question.


Have a nice day.

Re: Spotify on OS X 10.6.8

Casual Listener

Thank for your answer,

On this Macbook is not possible to upgrade more and all the web-browsers are not supported as WebPlayer.

0.8.5 is still live or Spotify is blocking the streaming from this side?


I'll try to format and reinstall



Re: Spotify on OS X 10.6.8


Hello, did you ever figure out a way to run Spotify on OS X 10.6.8?


As you rightly pointed out, it is not possible to upgrade the OS; nor to upgrade the web-browsers.


I am quite simply stuck!

Re: Spotify on OS X 10.6.8

Casual Listener
No solution by my side,
i fixed it installing a light version of linux that is able to run Spotify

Re: Spotify on OS X 10.6.8

Casual Listener

That's actually super sad. Just got my old Mac Book with OS X 10.6.8 back to work and now I'm sitting here not even getting Spotify to run on it.
The answer on
using version 0.8.5 no longer works.
I just tried out and it WORKED! Downloaded it from here: