Touch Bar issue when two applications playing.

Touch Bar issue when two applications playing.



I've migrated from Apple Music to Spotify after 4-5 years. I really love the application UI and lists etc. 


I wasn't waiting for a full compatible iOS experience, however even with google maps, it is not always working properly. But I'm not opening this thread because of this. 


My current issue is with Touch Bar and MacOS Play button. When Spotify is playing and it is only playing application, I can play/pause, change track easily. However, when there is another application is available and there is another media playing, even I click on the Spotify on Touch Bar, it controls the second media.


Other issue is, when there is no music application running, if I click on the play button on Touch Bar, it runs Apple Music which is annoying. Sometimes, it does that even when I'm listening a song from Spotify.







MacBook Pro 15" 2018, iPhone X


Operating System




7 Replies

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstall of the app. Just follow these steps.


About when other media is playing, macOS will use the media keys on the last media you started playing so if you are playing Spotify and open something on YouTube, you will have to stop and start playing Spotify again for that to work on Spotify and no YouTube.

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I'm not the original poster, but I'm having the same problem. I've tried restarting and a clean install, but the problem persists. When I expand the the touchbar to include both Chrome and Spotify media controls, no matter which app's controls are selected, it only controls the last app I accessed. I'm on MacOS Catalina 10.15.5, and Spotify v.

I reproduced this issue today. Please fix.

Hey there @_ps


Thanks for reaching out about this in the Community, and welcome 🙂 


Would you mind letting us know which troubleshooting steps you've tried? This will help us give you better suggestions. 


It would also be helpful if you could send over a video where we can take a better look at this issue. You can send a link to it or attach it using the Insert Video option in the post editor, just make sure to exclude any personal info from it. 


We'll keep an eye out for your reply. 

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Reboot/reinstall etc. doesn't work, issue exists even on the latest MacOS version. If the Spotify desktop application is running, it thinks all touchbar media control is meant for it. It isn't and Spotify breaks seek-pause/play in other apps. Very annoying.


I'm considering switching to Apple Music because of this and due to lack of HomePod support.

Hey @Avamander,

Thanks for reaching out. 

Just to double-check, did you try disabling the Hardware Acceleration? You can find it in the app's Settings > Compatibility or by clicking Spotify on the menu bar > Hardware Acceleration.


Something else you could also try out is check how you can customize the touch bar with the steps here. If this doesn't do it for you and the above mentioned behavior of the App continues - the best solution here would be checking with Apple Support. 

Hope that helps. 

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Open the 'Applications' section and swipe right to the 'All' tab and then find 'Google Play Store'. Open this up and tap 'Clear data'. Now reboot your phone, open the Play Store, and re-login. Afterward, try to install the Spotify app again.




Suggested posts