Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

[Web Player] Music skipping automatically, only some songs will play

[Web Player] Music skipping automatically, only some songs will play

I use the Spotify web player exclusively on my Mac, and found that two days ago it's just outright skipping songs, sometimes after not playing them at all, sometimes after playing 1-3 seconds of the song, however rarely one song will play just fine.

 

I've tried using a different account, clearing my cache and cookies, disabling my addons, but nothing's worked.

I use Spotify on Firefox on a Mid-2012 Mac running Catalina. The web player's run perfectly fine in the past and nothing on this computer has heavily changed since it last worked fine. My internet connection is fine.

 

People seem to have encountered this issue in the past, but I've tried as much as I can from those threads and nothing appears to work.

Reply
17 Replies

Hey there @CntrolCoreAngel,

 

Thanks for reaching out here in the Community, and welcome 🙂

 

We'd first recommend making sure that your browser is running it's latest version. 

 

If this doesn't do the trick, could you check if the same thing happens with a different browser?

 

Keep us posted on how it goes.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I have the same issue on an older netbook with the latest Firefox 32-Bit Linux Mint-version. Only the commercial adds work. The other tracks will be skipped. Maybe it has to do with changes in the digital rights management and my Firefox or System aren't compatible anymore.

Hey @orborb01,

 

Thanks for posting.

 

Could you let us know if you experience the same thing when using an incognito window or a different browser altogether? Does the same thing happen on other devices as well?

 

Keep us posted.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I've tried it in an incognito window with an alternate account and it still doesn't work. I've cleared cache and cookies before of course. The Firefox browser (32-Bit) is the last option for this old netbook with atom cpu (32 bit). It is the only supported browser and there is no Desktop app (32 bit) anymore for that system. I've just got an update fire the browser last weekend. So it is up-to-date.

Hi there @orborb01,

 

Thank you for your reply and confirmation.

 

Can you ensure plug-ins are whitelisted: Settings > Advanced > Privacy > Plugins > Manage Exceptions > http://spotify.com.

 

On another note, can you try restarting your router to see if the issue persist?

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I've managed exceptions for spotify.com and restarted the router. It didn't help. I use the latest Firefox browser for Linux Mint on an old 32-bit netbook. It is the only browser for this system, that still supports the Spotify webplayer. I only have this problem on this system. On other PCs I don't have this issue. All other audio streaming services work perfectly with this version of Firefox. So I don't think there is a general problem with my system.

Thanks for the detailed explanation of the troubleshooting you've tried @orborb01!

 

Could you send us a video recording of what the issue looks like exactly?

 

Does this happen only when listening to song, or with playlists as well?

 

We'd also suggest making sure that your sound drivers are up to date.

 

Keep us in the loop!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Thank you so far! A song in any playlist starts to play and sometimes I can hear the first 9 seconds of a song. After that it skips to the next song. Sometimes the playing just stops after a few seconds and nothing happens until I refresh the browser. If there would be an issue with the audio driver, I couldn't hear any music at all on Spotify. Unfortunately it is not possible to record a video on that old netbook.
I've updated the Linux system and the Firefox browser. All audio files are played well at other audio streaming platforms. So I can't imagine that there is an issue with the audio drivers. It was a fresh installation of Linux Mint and the Spotify webplayer worked well for months. The issue suddenly started without making any changes to my system. I've only used this netbook for listening to music. Every other music I am listening to on it works well (internet radio stations, audio files, alternate audio streaming services to Spotify).

Hey @orborb01,

 

Thank you for getting back to us and confirming what you've done so far.

 

Could you try flushing the DNS of your Linux? This way the whole system can remove any saved cache, this step more thorough than a regular cache clearing done on the browser. 

 

Keep us posted!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I already did a DNS flush. Unfortunately I didn't help with this specific problem.

Hey @orborb01,

 

Thanks for the follow up. 

 

Is it possible to connect your PC to a different internet network and see how it works? 

 

Also, can you try disabling momentarily the Firewall and the Antivirus on your PC, and try again?

 

Let us know how it goes. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I tired it at another place with a different internet provider, disabled the firewall and antivirus protection. It still doesn't work. I don't think it has to do with the router or internet. Three of my other devices work well with the Spotify webplayer.

Hey @orborb01,

 

Thank you for getting back to us. 

 

Could you please follow the steps provided in this thread to update your Widewine plugin in Firefox, and let us know if it helps?  

 

We'll be on the lookout. 

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

I've updated Firefox to Firefox 90.0 (32-Bit) for Linux Mint. The Widevine plugin version is 4.10.1582.2 and the last update is from 10.07.2021. I don't think it has do do with Widevine because my other audio streaming service, that also uses Widevinde, works well on my netbook.

Hi there @orborb01,

 

Thanks for giving those steps a try!

 

After all this troubleshooting, we feel this is most likely isolated to your device or specific setup.

 

We understand that it can feel frustrating when things don't work as you'd like them to. Rest assured that we're always trying to improve as we  continuously  strive to do better, but we’re not able to confirm if or when your specific issue will be resolved.

 

Let us know if we can help you with anything else. 

 

Take care! 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Okay! Thank you for your advice so far. I'll write again, if I get it back to work. Maybe this issue disappears with any updates. Or I could test it again in a Live Linux system. That's near to a fresh installation.

I guess I've found a reason for the skipping behaviour in my case for the 32-Bit Linux system. There is an article that says, that Google stopped the Widevine support for 32-Bit browser in May 2021. There are also problems at the moment with other streaming plattforms (f.e. video streaming) that also use Widevine. It seems, that the Firefox browser is up-to-date, but it really isn't if it comes to the Widevine plugin.

Suggested posts