Announcements

autoplays even when autoplay is turned off

autoplays even when autoplay is turned off

yrstrulym

Plan: Premium

USA

 

Device

mac

Operating System

monterey 12.0.1

 

i have the autoplay option toggled to off and never had a problem but i updated to spotify 1.1.72.439.gc253025e today and now it's autoplaying after the album ends.  i've tried quitting spotify and re-opening.  sometimes it plays songs by other artists and sometimes by the same artist.

 

help!

 

Reply
12 Replies

Jeremy

Hi there @yrstrulym,

 

Thank you for reaching out to the Community.

 

Can you perform a clean reinstall of the app? This will make sure there's no old cache files causing this.

 

If that doesn't do the trick, can you have someone log in with their account on your device - such as a friend or a family member to see if the issue persists?

We'll keep an eye out for your reply.

 

Take care!

 

 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

yrstrulym

i tried a clean install a few times - including using an app cleaner tool to make sure all files were deleted.  the problem persists.  unfortunately i do not know anyone else with an account who can try logging in.  are there any other ideas?

MafeG

Hi @yrstrulym,

 

Thank you for keeping in touch. 

 

We'd like to make sure of the following. Is this issue happening when you're using the Connect feature to stream to another device, or only when you're using your computer's speaker/headphones? 

 

Also, does the same happen if you use another device such as a phone or tablet? 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

yrstrulym

yes, it happens when i stream to my sonos or just play on my computer.

Alex

Hey @yrstrulym,

 

Thanks for the reply.

 

Can you let us know if you're seeing the same Autoplay settings as shown below and make sure they're switched Off.

 

 

We'll be on the lookout for your reply.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

yrstrulym

i did one final clean reinstall and toggled the autoplay button.  when i played on my computer it didn't autoplay but when i streamed to my sonos it did.

 

however, my toggles are different than what your screenshot above says.  i only have one option.  please see screenshot below.

Screen Shot 2021-12-06 at 12.06.54.png

CarlosE

Hey @yrstrulym,

 

Thanks for your reply and the screenshot.

 

This new toggle to disable Autoplay on other devices is currently being rolled out, so you should have it soon. Make sure to keep the app updated so you don't miss out on any improvements and new features.

 

If the issue persists on your Sonos even after having that toggle available and set to off, let us know.

 

The Community is here for you in case you have any questions.

 

Cheers!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

yrstrulym

thanks.  i looked at which version i was using and saw i had two updates available.  so i updated and now have the most recent version but unfortunately still do not have that option.  i guess i'll just wait until that update is available to me and then re-test.  thanks.

yrstrulym

this also happens when i stream from my phone to my sonos.  autoplay is unselected (of course i can only access the playback menu when the output is selected as my phone and not the sonos.  when the output is on sonos i cannot access the playback menu at all).  i am playing through the spotify app and not the sonos app, so it's unclear to me why, when streaming to another device, i encounter this problem.  

CarlosE

Hey @yrstrulym,

 

The Autoplay option was recently set to on automatically when using Connect. However, and thanks to the users' feedback, we're now rolling out that option to toggle it on/off at will on other devices.

 

Right now, the behavior you're describing is expected, but no worries, although we can't set an exact date, you should have that new toggle available soon so you can disable Autoplay on your Sonos speaker.

 

Thanks for your patience.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Grubama

It also happens to me even when I did everything mentioned above

Dian

Hey @Grubama,

 

Thanks for posting in the Community.

 

Could you let us know if this happens while using Connect or while playing songs on one device only?

 

What are the device's brand/model and operating system?

 

Which troubleshooting steps have you tried?

 

Keep us posted,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts

Env: prod