A problem with spotify desktop app not showing me my friendly activity

A problem with spotify desktop app not showing me my friendly activity

I have hade the app on two different computers and a laptop but still! It tells me to turn on "share my listening activity on spotify" to see others... even though it is already on! What should I do?

I have already tried reinstalling and restarting multiple times....
1 Reply

Hey @kais12345,


Thank you for reaching out here in the Community

If your friends have the setting toggled to on (see screenshot below) on their end and you have followed them in your profile, then they should be appearing in your Friends' feed. Keep in mind that the enabling of this option is for them to decide and we can't influence that. 


The Friends' feed itself could be hidden or made visible by going to the 3-dotted menu on your desktop app and navigating to View>Friend Activity, where you can check it on or off.


It's also worthwhile restarting the app twice in a row, as this triggers a refresh between the app and your account and may help to resolve any possible cache-related issues. 

Lastly, we'd recommend that you take a look at this article to see what else you can do to fix it.


Hope this helps. Don't hesitate to give us a shout if there's anything else we can help with 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts