Connected devices not showing in iOS

Reply

Connected devices not showing in iOS

psweetie
Casual Listener

 

When running Spotify on Windows 10 it correctly shows my two Naim devices and can playback on either with no problem.

 

However, if I try it from my iPhone or my iPad the devices do not appear on the list UNLESS the PC is already casting to the device. As soon as that stops they disappear from the list. 

Note that this has worked but nothing has changed with my network in the interim and there has been no new software on the Naim devices, just new versions of the Spotify app . . .

4 Replies

Re: Connected devices not showing in iOS

SergioDavid
Roadie

Hey @psweetie, welcome to the Community!

 

Sorry to hear you're having trouble with this. We'll definitely be able to help out though.

 

When did this start happening? Does the issue persist if you reset the network that your devices are connected to?

 

Let us know if that helps :)

Re: Connected devices not showing in iOS

psweetie
Casual Listener
Noticed it last week but havent used for a while. And have tried all resets on routers switches etc

Re: Connected devices not showing in iOS

SergioDavid
Roadie

Hey @psweetie.

 

Thanks for getting back in touch with that info.

 

In this case, it's best if you try a quick reinstall to see if it makes a difference.

 

Let us know how it goes.

Highlighted

Re: Connected devices not showing in iOS

mrxtc007_2k2
Visitor

So after months of not being able to fix this issue of my other devices not showing up on "Connect to a device" I was dinally able to fix the iusse by doing the following on my iMac: 

MAC

  1. Click Spotify in the menu bar then Quit Spotify.
  2. Open Finder then click Go > Library in the menu bar. (You may need to hold the Alt key if Library isn’t visible).
  3. Open Caches and delete the com.spotify.Client folder.
  4. Click the back arrow.
  5. Open Application Support and delete the Spotify folder.
  6. Download and install Spotify.

I had tried uninstalling Spotify before but what I was not doing was deleting the caches and spotify folder in Application Support. After doing so and re-installing Spotify and loggin back in, all my devices showed up. Glad to finally have that working after not having the option for a LONG time! 

 

Link in case anyone else needs assistance to uninstall from different operating system:

https://support.spotify.com/us/using_spotify/troubleshooting/reinstallation-of-spotify/

 

 

 

 

 

SUGGESTED POSTS