Enable Explicit Songs by disabling 'Hardware acceleration"?!

Reply

Enable Explicit Songs by disabling 'Hardware acceleration"?!

Kaya77
Regular

Spotify premium on Windows 7

I had a weird problem with Spotify doesn't playing any songs with explicit content, and there was nowhere in the settings where I could turn it on/off.
Then I read on another thread that people who had problems with Spotify couldn't play any songs at all, and that turning off "hardware acceleration" could help.  I tried this on my problem, and Spotify started playing songs with explicit contant again.

Isn't this really weird since hardware acceleration and songs with explicit content don't have anything "in common"?

2 Replies

Re: Enable Explicit Songs by disabling 'Hardware acceleration"?!

Rock Star 16
Rock Star 16

Hey @Kaya77

 

That's indeed a weird issue!

 

I'm also on Windows 7 and I can play all songs, including explicit ones (queued one and it plays fine right now).

I'd suggest reinstalling Spotify. Before you redownload it, I recommend restarting your computer. It could be that the client needs a little refresh. :)

 

Let me know how it goes!

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Enable Explicit Songs by disabling 'Hardware acceleration"?!

Kaya77
Regular
I did work after I disabled Hardware Acceleration. Thanks.
SUGGESTED POSTS