Announcements

Help! - Some songs won't play.

Solved!

Help! - Some songs won't play.

seberi

Hi, I'm getting really frustrated here.

For over a week now some songs won't start playing when I click them or when it gets to their turn to be played.

 

Examples:

Heinrich Dressel - The black radiant sky

Lost years - Breeze

 

Everything's looks as it should, besides that the marker that moves along as the song plays, the minute counter and the track length doesn't appear. And of course there's no sound!  

 

They're not local files - just playlists I've built here on my Spotify unlimited account.

And it's not always the same songs that have this problem. Some has started working again, while new songs gets the problem instead!

 

Tried reinstalling Spotify, setting back my computer, checking for viruses - nothing works and it's driving me crazy!

 

Really appreciate if someone could help me out!

Reply

Accepted Solutions
Marked as solution

abenavides

Ok ! This Might Work !!

 

 

This is only for the Program Version !

 

Go to EDIT>PREFRENCES>

Scroll Down to LOCAL FILES   And UN-check All the Boxes !   

 

Don't Allow a link between your iTunes or whatever OTHER SOURCE of music you use to your Spotify !

 

I've Downloaded some albums and threw them on my iTunes. And Spotify would add them to it's LOCAL FILES Area.

 

Hope This Helps !!  

 

It did for me !

View solution in original post

Marked as solution

ABOIX14

For me, the songs that wouldn't play were the ones I've bought on itunes so I went into EDIT>PREFERENCES, THEN SCROLLED DOWN TO LOCAL FILES and turned off (slide to the left) the tab next to ITUNES, WINDOWS MEDIA PLAYER, & MY MUSIC. (or whatever source you may or may not have).

 

that helped me, ...hope it helps you 🙂

View solution in original post

Marked as solution

kopicbloodaxe
Perfect! Fixed the issue for me. Thanks 🙂

View solution in original post

67 Replies

oloS

I have the same problem. 

It's not fair...

Spotify, do somthing with it, we pay you for streaming music!

 

For example, three pieces in a row don't play some minutes ago:

Zrzut ekranu 2013-11-6 o 14.29.13.pngZrzut ekranu 2013-11-6 o 14.29.43.pngZrzut ekranu 2013-11-6 o 14.29.54.png

 

OS X 10.8.5

Spotify Premium v. 0.9.4.185.g7545a404

Stitch

Same problem. :o( I'm paying a tenner a month for this? Here's one that won't play for me. I've done the recommended erasing and reinstalling. No luck.

Throwing Muses – Santa Claus

Illuminaire

I have the same problem.

reih

Same problem, and it seems to work for some people when you switch high quality streaming off in the edit - preferences section. But that is not a solution. Only a bad workaround. I 'm paying 10 euro/month just to have high quality. So is there somebody with better solutions/workarouds?

 

windows 7
ver: 0.9.4.185

459

I have similar problems as you do with four of the nine songs on album Pallas - The Cross & The Crucible. The songs don't start to play at all. I tried some of the mentioned songs here and they at least started to play with my computer. I have Spotify Unlimited and HQ is thereby disabled.

Herregaard

I have the same problem, certain songs just won't play. I have to forward to the next track to resume playing. It's been like this for a week or so. 

 

Vers 0.9.4.185

OS X, 10.9 Mavericks

freedom

Hello!

 

I am having the same problem!

I'm paying for unlimited!

But I discovered the webplayer https://play.spotify.com/user

and it saved my day! There the track worked

 I can't live without music!

 

I tried reinstalling it didn't work

 

I hope it will be solved soon!!!!!

 

 

Joe

Following issues with streamed music over the weekend, deleting your spotify cache and restarting spotify should get things back to normal.

oloS

Unfortunately it doesn't work.

Zrzut ekranu 2013-11-7 o 09.45.35.pngZrzut ekranu 2013-11-7 o 10.24.46.pngZrzut ekranu 2013-11-7 o 10.33.01.png

Peter__

Just adjusting the streaming quality in Edit > Preferences > Playback and then restarting the client make a difference? 

 

Would it be possible to catch the console output for Spotify and see if any error messages are being logged in the background? 

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

oloS
I pay for Spotify Premium, including due to the better quality
 
in attachment Spotify logs

langhorn

Same problem here. On three different Macs. Getting very annoying

Peter__

Thanks for the logs @langhorn 🙂

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

langhorn

Sorry Peter. I´m getting these errors

 

12:36:08.039 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:16.592 I [audio_streamer.cpp:538          ] 64k-Latency: 8557 ms. Play latency: 8503 ms (ap)

12:36:27.012 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:31.855 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:32.314 I [audio_streamer.cpp:538          ] 64k-Latency: 464 ms. Play latency: 436 ms (ap)

12:36:34.093 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:39.337 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

 

is that enough or do you need the whole log?

Peter__

@langhorn wrote:

Sorry Peter. I´m getting these errors

 

12:36:08.039 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:16.592 I [audio_streamer.cpp:538          ] 64k-Latency: 8557 ms. Play latency: 8503 ms (ap)

12:36:27.012 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:31.855 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:32.314 I [audio_streamer.cpp:538          ] 64k-Latency: 464 ms. Play latency: 436 ms (ap)

12:36:34.093 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

12:36:39.337 I [AppManager.cpp:297              ] Keeping application artist alive because it is "playing".

 

is that enough or do you need the whole log?


Would be handy if we could get the whole log - there are no error messages there 😉 

 

Any error message will have:

12:36:39.337 E

 

For example.

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

MrDelicious

Is there a way to view the logs on Windows?

langhorn

Hi guys,

 

To help us troubleshoot this, it'd be super-helpful if the more technical amongst you could post some Console outputs:

 

  • For console output using Windows: Start the client with commandline argument -c.
  • For console output using Windows with client running: Hit ctrl-alt-home with an open client.
  • For console output using OSX: Start the client with the terminal: /Applications/Spotify.app/Contents/MacOS/Spotify.
  • For console output using OSX with client running: open Console and filter on spotify.client.

langhorn

Peter, I sent the log to you as a private mess, dunno why, just felt better

Peter__

Thanks @langhorn 🙂 

 

I'll add them to the bug report in the super user area 😉 

 

If anyone else has logs, if you can either post them here or PM them to me either is good! 

 

Thanks guys!

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Suggested posts

Env: prod