Local files partially not being recognised or ignored

Reply

Local files partially not being recognised or ignored

bergzwerver
Regular

Over time I have made playlists with music from other sources than spotify multiple times, and I started to notice that in these playlists certain songs seem to dissapear. In addition to that, some songs that I have locally are being replaced by their online counterpart, which isn't too much of a big deal but kind of annoying as it changes the album cover to not fit in with the rest of the playlist sometimes. An example to illustrate:

 

A playlist I downloaded from adult swim, located in my music library which should be recognised anyway.

 

In an attempt to fix it I added this specific folder as a source location:

 

This did nothing, as you can see some files are recognised, some are not and some are replaced by online counterparts:

 

Asside from the playlist I put them in a while back, they also don't appear in local files.

 

I've seen people have problems with local files not showing at all, and I've tried suggested fixes for that like reïnstalling and adding source locations for local files, but nothing seems to help.

 

Any suggestions on how to get my broken playlists complete again?

 

 

2 Replies

bergzwerver
Regular

Still haven't found a solution. I don't understand why this is even happening, files from the same album, which are stored in the exact same location are partially recognised and partially impossible to get back in spotify.

kebykepow
Casual Listener

Unlink local files folder change its name, add it back into spotify local files (with the changed folder name), Unlink the folder again, change name back to original and link it again at spotify local files. This should refresh the tab "your music, Local Files" and your music should be available again in your other playlists.

 

1. unlink local files folder "Edit > Preferences > Local files > "disable" (driveletter):/(foldersongs)

2. go to that folder where the songs are change its name "(Foldersongs)" to
"(Foldersongs1)"

3. link local files folder "Edit > Preferences > Local files > "enable" (driveletter):/(foldername(Foldersongs1))

4. unlink local files folder "Edit > Preferences > Local files > "disable" (driveletter):/(foldername(Foldersongs1))

5. go to that folder where the songs are change its name back to "(Foldersongs)"

6. link local files folder "Edit > Preferences > Local files > "enable" (driveletter):/(foldersongs) again.

Fixed it for me! hope you dont have to redo this often (spotify PLS fix XD)

SUGGESTED POSTS