Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Media Keys no longer working if Spotify isn't the active window.

Media Keys no longer working if Spotify isn't the active window.

I have been using my media keys with Spotify in the background flawlessly for quite a while but suddenly they've stopped working. They only work with Spotify if I have Spotify as my active window (in the foreground). I have Google Chrome installed but I do not have Google Play Music or any other media extensions installed/enabled, I do not have Windows Media Player Services, and I'm pretty sure I don't have any other programs or processes running in the background that would cause any interference. I'm using an Asus Transformerbook Flip running Windows 10. This is a pretty big issue for me because it interrupts my workflow having to stop what I'm doing to click the window just to change songs or constantly restart Spotify for a temporary fix for my media keys. Is there a fix out there for this?

4 Replies

I am also experiencing this issue. Media keys have been working flawlessly, however, recently they only work if the Spotify app has focus. I am also running Windows 10. My issue may have started after Windows update v.1511.

EDIT: Bizarrely, this started working again. Not sure if this was related to a Windows update.



chrome://flags/#hardware-media-key-handling - disabled


Spotify as a windows app does not allow me to set it as a default, which may impact global media keys. 



Hey folks,

Thanks posting here in the Community! We'll gladly help you out.

We recommend that you perform a clean reinstall using these steps. This way you make sure that no corrupted files remain, that could be causing this issue. You should also try out  both the MicrosoftStore version of the app, as well as the one from our website, to see if this makes a difference.

If the problem persists, you have a look at this thread and the comments that are marked as solutions. It seems that there are quite a few different ways that other users solved this problem, you should try them out.

Hope this helps. Keep us posted on your progress.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Had te same issue, re-installing fixed it for me.

Suggested posts