Pausing Spotify Playback "Mutes" ALL Audio Playback On My Computer

Solved!
Reply

Pausing Spotify Playback "Mutes" ALL Audio Playback On My Computer

DuskArgentum
Newbie

Hi, everyone.

I installed a Windows update today. After the update, Spotify seems to be acting strangely. Like the title says, pausing audio playback mutes all other sound output on my computer, including my web browser, and games on Steam.
I tried Googling around for a solution, and found a webpage from the Spotify community that advertises itself as a solution to my problem, however, I keep getting the error "You do not have sufficient privileges for this resource or its parent to perform this action.

Click your browser's Back button to continue.". Google "pausing spotify pauses all sound on computer", it should be the first result, if you want to see it for yourself.

I've restarted my computer, disabled and reenabled my audio output device, restarted Spotify, everything (minus reinstalling Spotify, yet, since that's kind of a last ditch effort). I'm (or should be) on the most recent build of Windows 10, and am on version "1.0.80.474.gef6b503e (Windows Store version)" of Spotify.

Any help would be appreciated!

1 ACCEPTED SOLUTION
Solution!

0x1h-qjnk_ug0
Casual Listener

There is a fix everyone!

 

Just go to Edit -> preferences -< Display options and disable "Show desktop overlay when using media keys"

 

This fixed my issue atleast. 

 

Thanks to @johbuldmann for finding this. 

View solution in original post

26 Replies

eljazira
Newbie

Same here at two diffrent machines with Bluetooth headset

On my android phone - oneplus 3t and on my Windows 10 laptop (dell xps 15 9570)

When I pause spotify - I lose all the audio on the device.

I think it has something to do with the spotify app

 

Solution!

0x1h-qjnk_ug0
Casual Listener

There is a fix everyone!

 

Just go to Edit -> preferences -< Display options and disable "Show desktop overlay when using media keys"

 

This fixed my issue atleast. 

 

Thanks to @johbuldmann for finding this. 

View solution in original post

j-c_yc863xful
Newbie

Doesn't permanently fix the problem. I have to re-apply the solution every time I open spotify

user-removed
Not applicable

I'm having the same issue on macOS.

MacOS: 10.14.2

Spotify: 1.0.96.181.gf6bc1b6b

 

SGTAce
Casual Listener

Okay I think I got this.

- don't pause spotify, just close it, watch some youtube or something else you were suppose to watch

- don't open it back 😄 😄 😄 😄

 

 

(works for me 100% of the time)

SGTAce
Casual Listener

They have to fix this :<. If I disable overlay I don't have control over my music on headphones. 2/10

AvatharTOS
Casual Listener

This doesnt seem to work on OSX version of Spotify where this option isnt available, has anyone managed to solve this for Apple machines?

 

Will try it on my windows computer tonight though.

benbr_
Regular

I haven't been able to solve this issue on mac either. One thing is that I don't have the issue with my bluetooth speakers, just my earphones. I think it could be because my earphones use aptx. When I disable aptx on my mac the spotify issue stops happening, but of course the audio quality is bad.

 

It's probably worth creating an issue on the mac forum, as this is the windows forum and a solution has been set it probably won't get any attention from spotify.

lunawasp
Newbie

Did anyone manage to find a solution for Mac?

J7Luke
Casual Listener

You are my hero!!!  I have been trying to solve that for ages.  Thanks so much!!!

pdxgeek421
Regular

This worked for me as well. Thank you!!!

user-removed
Not applicable

I have only tested this briefly but it appears to have worked for me too. Thank you!

benbr_
Regular

I've done some more experimenting and I think this issue might be related to aptX which is the bluetooth codec used when listening to music through bluetooth earphones.

 

When my computer is using a difference bluetooth codec (SSO for example) the issue does not occur (though the audio quality is aweful due to bluetooth limitations). I've tried this on a mac which switches to SSO when I'm using the mic on my earphones.

 

So if I'm using the mic then the issue doesn't occur

 

I'll test this out on my windows work computer next week to see if it's the same there. 

jet_
Music Fan

same issue on Win10 with bluetooth headphones.

 

0x1h-qjnk_ug0
Casual Listener

Bump

 

Is there really no solution for this yet? Have had this problem for literally 4 months making me pretty much unable to use spotify on my desktop.

 

 

user-removed
Not applicable

Also having this issue and it's been driving me nuts for a month or 2 now. I also have to resort to just leaving Spotify playing on mute and skipping back on the missed tracks until I am done.

0x1h-qjnk_ug0
Casual Listener

Have had the same exact problem and for almost 2 months, but i just found out it is also happening in with itunes which should mean the problem is in windows? Because i am 100% sure it's not my BT headphones since they have worked fine for more than 2 years. 

 

No one have a solution yet? I dont want to use the online webplayer anymore, it's**bleep**.

benbr_
Regular

I'm having this issue as well. To recreate

  1. Connect bluetooth earphones
  2. Start spotify program but don't play anything - audio in chrome still works at this point
  3. Start playing audio in spotify - this mutes audio in Chrome even after pausing the track
  4. To fix issue, quit spotify fully

Spotify version: 1.0.84.344.gfc674f6f

OS: macOS High Sierra 10.13.5

Earphones: Sennheiser 6.00 CX bluetooth earphones

 

sld1025
Casual Listener

same exact issue! abut after after reading the responses/comments above me, it seems the issue is with the bluetooth device so i just turned my headphones and on off to reset the connection and that seemed to solve the issue (and this seems like an easier option than closing & re-opening my browser).

wx9b-lt1_marl
Visitor

I can confirm your Bluetooth suspicion. But it only seems to affect speakerphones. Other BT devices without a microphone don't behave that way.

SUGGESTED POSTS