Skipping through tracks on Desktop App

Solved!
Reply

Skipping through tracks on Desktop App

smalldridge
Casual Listener

Plan

Premium

Country

UK

Device

PC

Operating System

Windows 10

 

My Question or Issue

The Spotify desktop app *has* been working fine up until maybe a week ago. It now constantly skips through tracks without playing them.

All other audio works on the PC - including the Spotify Web Player. Spotify also works fine on my Android phone.

I have tried other solutions suggested on the Communtiy - reinstalling, rebooting, deleting the cache thing. But no joy. It is very annoying.

 

Any suggestions?

 

Thank you

1 ACCEPTED SOLUTION
Solution!

smalldridge
Casual Listener

I have managed to resolve by taking the following steps.

N.B I have 2 sound cards in my PC

 

  • Sound is currently controlled by Xonar DX Audio Center. Spotify was skipping tracks.
  • I unplugged speakers from the Xonar sound card and plugged into Realtek Soundcard.
  • In the Realtek HD Audio Manager, I selected 'Set Default Device'. Spotify was now playing correctly.
  • I then went into Sound Setting in Control Panel, and selected Xonar DX Audio as default output device. Spotify is now playing correctly and not skipping tracks.

It seems that one way or another, the PC was mixing up which drivers it was using for playback. If you have a secondary soundcard installed, I suggest checking that Spotify works properly on the original soundcard, then try again on the second.

View solution in original post

10 Replies
Solution!

smalldridge
Casual Listener

I have managed to resolve by taking the following steps.

N.B I have 2 sound cards in my PC

 

  • Sound is currently controlled by Xonar DX Audio Center. Spotify was skipping tracks.
  • I unplugged speakers from the Xonar sound card and plugged into Realtek Soundcard.
  • In the Realtek HD Audio Manager, I selected 'Set Default Device'. Spotify was now playing correctly.
  • I then went into Sound Setting in Control Panel, and selected Xonar DX Audio as default output device. Spotify is now playing correctly and not skipping tracks.

It seems that one way or another, the PC was mixing up which drivers it was using for playback. If you have a secondary soundcard installed, I suggest checking that Spotify works properly on the original soundcard, then try again on the second.

View solution in original post

mran1044
Regular

I have a Asus Xonar DG sound card and Spotify stopped working for me as well on my Desktop windows 10 PC. It works on my other devices. We really need Spotify to make their software support this common entry level sound card that many people still use. I messed with the default playback devices and it will not work with my sound card that has been listening to Spotify for years until just recently. I think they must of changed something that is making it not work for all of us. Thanks.

mran1044
Regular

Asus Xonar users on Windows 10- See the solution that worked for me on the other thread.

https://community.spotify.com/t5/Desktop-Windows/Spotify-skipping-all-songs/td-p/4989082

eltwinne89
Regular

Yes, this works. But it disables any 5.1 or 7.1... Its kind of a solution, but it doesnt fix it for us 5.1 users. Any ideas?

C0LDF1R3
Casual Listener
That works for me. Thank you very much.

C0LDF1R3
Casual Listener

I also had the same problem and I also have a xonar soundcart.

It just occured the day before yesterday when I installed a vpn client and connected with it.

 

I tried you advice, but I can't install Realtek HD Audio Manager. Windows 10 just wont let it happen. So I needed to use Realtek Audo Console. I did your steps but did not actually configure something. And now it somehow works again.

 

I am still not sure who/what is causing the problems here 😄

 

Regards,

C0LDF1R3

C0LDF1R3
Casual Listener

I just restarted the computer and the problem still exists...

Solanor
Visitor

I have the exact same problem here! It was working fine yesterday!

Ivan
Moderator
Moderator

Hey there @smalldridge and @Solanor

 

Thanks for reaching out to the Community about this. 
 

If you've noticed that playback skips through the songs without any sound it's possible that you're experiencing an issue that we're currently investigating in search for a solution. You can check out this Ongoing Issue and add your vote to it by clicking on the +VOTE button. Make sure you follow the steps provided under Status Update as well. 

 

It'll also be useful to subscribe via the three-dots menu in the top right corner next to the title. That'll make sure you stay up to date with any relevant updates about this.

 

Hope this helps. Let us know if you have any more questions.  

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

Ivan
Moderator
Moderator

Hey @smalldridge

 

Thanks for keeping us in the loop. 

 

We're happy to hear that this is now fixed for you. Also, thank you for sharing the steps for the solution you found since this might help other users experiencing the same issue.  

 

Enjoy the rest of your day and keep well!  

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp
SUGGESTED POSTS