Songs "Play" but no sound

Songs "Play" but no sound

So, I've been experiencing some problems with Spotify on my iPhone (not my iPhone being broken, stupid problem of the Spotify app itself) and now on my Windows 10, too!

The app will say a song is playing, but I have no sound. I tried plugging in and out my headphones, connect it with a speaker with BlueTooth, tried to fix the settings (which didn't work out) and tried to put up all the volume. If those things worked, I wouldn't bother writing a topic about it.

I know, there are many other topics that have the same problem and are all solved, but I just can't fix it.


Tips that are actually working would be nice..


Some extra information that might help:

I don't have Spotify Premium,

I have a Gaming Laptop, R.O.G. with the Windows 10.

I tried other things such as YouTube and I got sound, only Spotify won't work.



My Issue is:

No sound, but the song is playing, and all the other stuff on other topics won't work.




27 Replies

Hey there @SUNKIST


Thanks for reaching out about this and welcome to the Community. 


Could you let us know which troubleshooting steps you've already tried? That way we can avoid repeating any steps.


Also, sending us the the exact make/model, operating system and Spotify version of your devices would come in handy. 

We'll be waiting for your reply.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

It is probably me, but I find this forum hard to navigate so I just drop right here if that is ok.


So, I have been having I guess the same issues. Spotify does connect to my amp, my amp shows the song playing, but there is no sound. The problem first started that the song played but no sound and then out of nowhere the sound comes on. That now also does not happen anymore.


Spotify connect can also turn on my amp, makes no difference. Used two android phones, Macbook app and in browser. All same issue. Beyond frustrating.


No new firmware for the amp (Marantz SR5009)

Factory reset the amp

Rebooted the modem (I think it all started when I came back from holiday and turn my modem back on)

Since it is happening on all devices, reinstalling the app won't make a difference (plus on phone is brand new)

Google my **s off but did not find a solution.


Hope someone can help. Thanks in advance. 


Hi there @Pinpoint,


Thanks for the post.


Such issues with Spotify Connect on most amps come when there is a change made on Spotify's side and the amp manufacturers need some time to catch up with the changes and release a new firmware that supports them. This is because the Spotify app for amplifiers, sound systems and speakers is developed by the device manufacturer using Spotify API and not directly by Spotify.


I'd suggest you reach out to the support team from Marantz about this. They'll be able to shine more light on the matter.


Keep us posted on how you get on with this.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I personally just connected it to my Google Assistant and then disconnected and then restarted the app. If this help you, sorry!

I listen on the web player, it helped a little when i closed and reopened the website but it still skips a little. Anything for web player? I can't download because it is on a school computer. Spotify has worked perfectly before, but sometimes it does this

I hope this helps everyone with this issue.
It happened to me and while searching the internet to fix the issue, I found this solution:
On the taskbar, find and right-click the speakers' icon > Open volume mixer. In my case, they were muted. They were muted out of nowhere but I am glad it finally sorted out. 

Had this problem on PC and solved it. My problem was that I had muted the Spotify in volume mixer earlier and forgot about it, so check your Volume mixer (right click on sound icon down right near the clock on the desktop).

Hey @Škrbava_usta,


Welcome to the Community and thank you for joining the conversation.


We're glad to know that everything is working fine now. We appreciate the time you took posting what works for you. Hopefully, this tip will help other users too.


In case you need anything else, remember that we're just a post away.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts