Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify Not Playing

Spotify Not Playing

zplost

Plan

Premium

 

Device

Surface Pro

 

Operating System

Windows 10 version 1903

 

My Question or Issue

Normally, spotify app for my surface pro had working just fine. But all of the sudden, I get an error message at the top of the screen in blue with white copy and a white x. The copy reads, "Sporty can't play this right now. If you have this file on your computer you can import it." Additionally, when I do hit play, it also quickly flips between songs (without playing them) before popping the error message up.

 

I've tried uninstalling and reinstalling the app and still no success. Everything within the app seems to be working fine and my account works fine from my phone.

Reply
4 Replies

JaredLai

Me too. Did you just update windows? Cus I did and then the same issue happened.

zplost

My windows did go through an update but that was a little while ago. It's promoting me for another update now so I am going to update and see if that resolves any of the issues I'm having. It certainly won't stop spotify from working since that has already happened. I'll reply back and let you know what happens post-update

Stevie_Griffin

Yep, I've got precisely the same problem. Updated Windows then went away for the weekend, I've come back and booted my machine up and it just flicks through songs in rapid succession. It will get to the end of the album or playlist etc, then just stop, sit there and do nothing. I think it's very likely that it has something to do with the Windows update as Spotify works fine on the web version and also on my Android phone. 

zplost

I just went through an update and restarted my machine this morning and all seems to be working now. I had been pushing off the latest update for a few weeks but this seems to have resolved the issue. I suppose if you are due for a windows update, go ahead and let the machine update and restart and see if that does the trick. It worked for me.

Suggested posts