Spotify don´t play songs, can´t find them

Solved!
Reply
Highlighted

Spotify don´t play songs, can´t find them

MinimiStrix
Casual Listener

Plan

Free

Country

 Austria

Operating System

Windows 10

 

My Question or Issue

When i try to find songs in my Spotify app... I can´t play them. It also don´t show me the title or de Picture of the Title. When i go in my safed songs, it´s loading like 5 minutes and then show me my songs.

 

Kind Regards,

Minimistrix

 

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Spotify don´t play songs, can´t find them

Rock Star 16
Rock Star 16

Hey @MinimiStrix

 

I'd suggest checking your hosts file, that may cause the issue.

You'll need administrator rights. :)

 

Try this:

1. open Notepad as an administrator (right-click - Open as Administrator)
2. go to File - Open and navigate to

C:\Windows\System32\drivers\etc

3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open.
4. The file is opened. You will see a block of text with # in front of each line and might see entries like

0.0.0.0 website.com
127.0.0.1 website2.com

Check for any entries with spotify or fastly in the address. Examples may look like:

0.0.0.0 weblb-wg.gslb.spotify.com
0.0.0.0 prod.b.ssl.us-eu.fastlylb.net 

(and any variations inbetween)
5. If you do find any, you can delete the line. You can also add a # in front of the line, that's 'commenting out'.
6. Save your changes. Restart Spotify.

You can also try removing all lines to see what happens.

 

If that didn't help, let me know what network are you on (home or corporate) and does the web player work for you.

 

Keep me updated. :)

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

5 Replies
Solution!

Re: Spotify don´t play songs, can´t find them

Rock Star 16
Rock Star 16

Hey @MinimiStrix

 

I'd suggest checking your hosts file, that may cause the issue.

You'll need administrator rights. :)

 

Try this:

1. open Notepad as an administrator (right-click - Open as Administrator)
2. go to File - Open and navigate to

C:\Windows\System32\drivers\etc

3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open.
4. The file is opened. You will see a block of text with # in front of each line and might see entries like

0.0.0.0 website.com
127.0.0.1 website2.com

Check for any entries with spotify or fastly in the address. Examples may look like:

0.0.0.0 weblb-wg.gslb.spotify.com
0.0.0.0 prod.b.ssl.us-eu.fastlylb.net 

(and any variations inbetween)
5. If you do find any, you can delete the line. You can also add a # in front of the line, that's 'commenting out'.
6. Save your changes. Restart Spotify.

You can also try removing all lines to see what happens.

 

If that didn't help, let me know what network are you on (home or corporate) and does the web player work for you.

 

Keep me updated. :)

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Re: Spotify don´t play songs, can´t find them

MinimiStrix
Casual Listener

Thank you @Sebasty,

worked after i deletet all "spotify" lines in my host file

Re: Spotify don´t play songs, can´t find them

Ryou7
Regular

@Sebasty THANK YOU SOOOOOOOOOOOOOOOOOOOOOOOOOOO MUCH
You just solved my Spotify problem thank you sooo much, I couldn't play any musics and now I can!! I won't thank you much enough i think, but again thank you. <3

Re: Spotify don´t play songs, can´t find them

mira_w
Newbie

thank you !! I've been chatting with spotify customer support for hours and they couldn't find a solution and this solved it within one minute. again, thanks so much!

Re: Spotify don´t play songs, can´t find them

Variasam2
Newbie

@Sebasty Thank you SO much, I've been stuck with this issue for weeks now, couldn't figure it out at all. Worked like a charm :) Thanks again!!

SUGGESTED POSTS