Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify installer doesn't actually seem to install spotify (Windows 10)

Spotify installer doesn't actually seem to install spotify (Windows 10)

So the weird thing is that Spotify was working perfectly fine a couple weeks ago (it has been a while since I ran Spotify on this computer as this is my work computer). I went to start it up and noticed the icon missing from my task bar, clicking on the icon from my start bar wouldn't do anything either.


So I spent a bunch of time trying to re-install from both a full installer downloaded off the website, and from the windows store as well as restarting my machine seeing if anything would help, and nothing, clicking on the spotify icon just wouldn't do anything.


One thread I came across mentioned clearing out all spotify data from the AppData folder, and I realized that almost none of the spotify directories were there. There was one in ~/AppData/Roaming/Spotify, but this directory was empty. So I went to the desktop shortcut to try and open the file location, but that button was greyed out and the target path was some non-sensical path (SpotifyAB.SpotifyMusic_zpdnekdrzrea0!Spotify). So as far as I can tell, the Spotify shortcut isn't pointing to a proper location, and I've checked this several times after several re-installs. I did a search for the spotify executable through windows explorer, and I did find one (Spotify.exe) located in the ~/AppData/Local/Microsoft/WindowsApps directory, but using that didn't work either, and yes, I've run as administrator. I tried moving the executable, wondering if maybe it was some sort of write permission issue and I get an error that says "The file cannot be accessed by the system"


I'm completely stumped, I have no idea what's going on and I would like to get Spotify working again




0 Replies

Suggested posts