Spotify skips all songs immediately after I connected my Scarlett 2i2

Solved!
Reply

Spotify skips all songs immediately after I connected my Scarlett 2i2

SodaParty
Regular

Plan

Premium

Country

Norway

Device

Desktop

Operating System

Windows 10, latest version

 

My Question or Issue

I've tried everything. YouTube and stuff works perfectly.

  • Reinstalling Spotify
  • Clearing Spotify cache
  • Updating Java
  • Restarting my computer
  • Update drivers (web page says drivers aren't required for this product(?))
  • Change default playback device
  • Restart Windows Audio Endpoint Builder

Can't think of anything else, but I've probably done that too.

 

Just started school, so it's a bit crucial this works, haha.

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

SodaParty
Regular

I found the solution! For some reason all other programs are set to default speakers, except Spotify when you connect your Scarlett.

 

1. Right click volume icon in the bottom right corner of your desktop.

2. Click 'Open sound settings'

3. Scroll down to 'Advanced sound options' and click on 'App volume device preferences'.

4. Change Spotify to Scarlett 2i2 or any other desired input device.

View solution in original post

6 Replies

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

Rock Star 15
Rock Star 15

Hey there @SodaParty,

Thanks for posting !

 

Looks like you've already tried most common solutions so let's try removing Spotify from the Host file and see it it helps.

 

Please follow these steps:

  • Open Notepad as an administrator (right-click - Open as Administrator)
  • go to File - Open and navigate to C:\Windows\System32\drivers\etc
  • Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  • When the file is open, you will see a block of text with # in front of each line and might see entries like 0.0.0.0 website.com127.0.0.1 website2.com
  • Check for any entries with Spotify in the address. Examples may look like: 0.0.0.0 weblb-wg.gslb.spotify.com0.0.0.0
  • If you do find any lines with Spotify, please remove them.
  • Save your changes and restart Spotify.

Let me know how it goes :)

OneByBooRock Star 15
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

SodaParty
Regular
0.0.0.0 pubads.g.doubleclick.net
0.0.0.0 securepubads.g.doubleclick.net
0.0.0.0 pubads.g.doubleclick.net
0.0.0.0 securepubads.g.doubleclick.net

These are the only ones I've got. Are they Spotify related?

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

Moderator
Moderator

Hey @SodaParty,

To answer your question: 

No, these are not Spotify-related. Regarding the issue - what do you mean by it "skips all the songs"?

Can you describe how the set-up looks - what's connected to what in which way? :)

We're waiting for your reply and are ready to help further!

Have an enjoyable day!

DaisyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

Der_Lemac
Casual Listener

Hello, I have same problem only without Scarlett 2i2 that skip-problem starts with the moment I press play :)
It started some time ago and I have tried everything that came to mind to this day the last thing would be a completely reinstall of Windwos, but I don't really want to :D

The good news is that I have found a solution which is not optimal but works or me:

I start the web player in a Brwoser which is not normally used by me then I can use the desktop app as a remote control.

Maybe that helped you a little or someone else comes up with an idea.

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

Moderator
Moderator

Hello @Der_Lemac and @SodaParty,

 

Could you please try to log in with a different account if you are still experiencing this issue. For example the account from a friend or family member. That way we can find out if something is wrong with your account.

 

Let us know how it goes.

 

Have a nice day!

GuidoModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
Solution!

Re: Spotify skips all songs immediately after I connected my Scarlett 2i2

SodaParty
Regular

I found the solution! For some reason all other programs are set to default speakers, except Spotify when you connect your Scarlett.

 

1. Right click volume icon in the bottom right corner of your desktop.

2. Click 'Open sound settings'

3. Scroll down to 'Advanced sound options' and click on 'App volume device preferences'.

4. Change Spotify to Scarlett 2i2 or any other desired input device.

View solution in original post

SUGGESTED POSTS