Announcements

Having trouble seeing your Wrapped stories? To fix this, update the Spotify app to the latest version.

Find more info on our community FAQ.

Spotify stays in foreground

Spotify stays in foreground

My Issue

When I ALT+Tab  or click outside the Spotify window, it stays in foreground and doesn't go in background. The only workaround is to press the icon to minimize it (which technically isn't the same thing as making it go in the background). This is pretty annoying because I can't ALT+Tab anymore to quickly switch between apps.

Troubleshooting

If I force close and open Spotify again it works properly, hence it's only happening when Spotify is auto-started during Windows startup. 

I'm not sure when this issue started happening, probably more than a month ago. The last 2 updates didn't fix this.

It may be related to the Windows 20H2 update but I'm not sure.

Plan

Premium

Country

Italy

Operating System

Windows 10 20H2

 

 

Reply
10 Replies

Hi there @Vermat99,


Thanks for reaching out about this.

 

In this case we can recommend running a clean reinstall of the app, which involves deleting the app cache. You can find the device relevant steps here.

 

Can you also let us know if this happens only if the app window is maximized or when it's not on full screen too.

 

We'll be on the lookout for your reply.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

---

A clean reinstall hasn't fixed it.
Happens both if the window is full screen or isn't full screen.
After the install, looked solved for a couple of days. But today i booted the PC and the issue was there again.
Also, I noticed that Spotify, even when "working", doesn't have the standard Windows animation for minimizing/bringing up the window, unlike all the other apps. Probably this is also related to the main issue.

Hey @Vermat99,

 

Thank you for your post and confirmation.

 

Can you try the following:

  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like 0.0.0.0 website.com127.0.0.1 website2.com
  5. Check for any entries with Spotify in the address. Examples may look like: 0.0.0.0 weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them
  7. Save your changes and restart Spotify

Also - can you let us know which Spotify version you've downloaded - from the Microsoft store or from the Spotify site?

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I'm using version 1.1.46.916.g416cacf1 from Microsoft store.

Nothing mentioning spotify in the hosts file.

 

Hey again @Vermat99,

 

Thank you for your reply 🙂

 

Can you try to download Spotify from the Spotify site to see if the issue persists?

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Okay I tried for a week and can confirm the issue in not present in the non-store version of the app. However I got other worst issues with that app (can't switch player in the overlay, "the Spotify application is not responding") and reverted to the Windows store version.

Hey @Vermat99.

 

Thank you for your reply. We're sorry to hear that you experience this.

 

Can you disable Hardware Acceleration from Settings > Advanced > Compatibility and restart the app then use his PC as normal for a while and check if the same thing happens after the next reboot?

 

Keep us posted 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I already tried disabling Hardware acceleration and didn't solve the issue. 

However, after reinstalling the the Windows Store version, Spotify always goes in background as it should. It's about a week I have installed it and never had the issue, so I think it is fair to say it is fixed! Thank you for your help. 

 

If I have to be picky, it's still the only window not having the minimize/maximize animations, but that's not a big deal!

Hey there @Vermat99,

 

Thank you for your reply and confirmation.


We're really glad to hear that everything works as it should for you again 🙂

 

If you'd like to, you can provide us a screenshot so we can take a closer look.

 

If anything comes up we're always one reply away.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts