Announcements

Spotify won't play "local files" songs!

Solved!

Spotify won't play "local files" songs!

barthelemy_gas

Hi there!

 

When I want to play files from "local files", some of them won't play. I don't really understand why ?

They've been imported from itunes. The bottom bar doesn't show anything and the "point" has disappeared!

 

If any of you got an idea? 

Cheers! 

Reply
86 Replies

zinna123

Im having the same problem I have a PC and no local tracks are playing 

LesBecky

The codec worked perfectly. Thank you so much!

HxcRobb

Ok, next try installing a new codec such as the one at http://www.free-codecs.com/mpeg_layer_3_codec_download.htm

In the meantime I'll see if there's anything else that could be causing this.

 

Worked!!!!!

 

Thank you Moderator! It's not often I find a solution quickly like this. +1 to Spotify community

jmb

What would MAC users do? I have the same problem - can't install QT ( it says QT is part of OS). Yet, my itunes files ( all DRM free AAC) don't play it spotify ( in my Mountain Lion MBP as well as the android phones/IOS etc)

Richard

@jmb wrote:

What would MAC users do? I have the same problem - can't install QT ( it says QT is part of OS). Yet, my itunes files ( all DRM free AAC) don't play it spotify ( in my Mountain Lion MBP as well as the android phones/IOS etc)


Could you possibly start/join a topic over in the Mac board? It might get a bit confusing try to troubleshoot across operating systems otherwise.

Check out our Twitter for the latest updates on any service issues: @Spotifystatus

Problem solved? Click 'Accept as solution' to make it easier to find for others!

New to the Community? Check out our Community newbie tips

SexWax45

Hello, I have read this entire thread and have done all the possible fixes listed, installed quick time, installed the mp3 codec, reinstalled spotify, moved the files to desktop, unchecked the sources in the local files area of the prefrences, but to no avail. It is odd that the tracks are mp3 tracks that play in WMP, winamp, iTunes, but are unable to play in Spoitfy. I don't receive any messages saying that the song won't play and it acutally looks like the song is playing, changes frome play to pause button, but it gets stuck on the first second. This is really annoying when using a playlist because it just stops playing in the middle without warning, are their any other ideas that may resolve this issue. Any ideas are greatly appreicated.

 

Oh and if you are Reading this just know that spotify forum moderators suck sacks, because they never reply and they obviously don't care about fatal flaws with their software.

jennychan12

It's not playing some of my "local files". Like the albums I purchased.

mrthorn10

For all of those who didnt even want to have local files on spotify-->

First, I went to edit> Preferences > Local files > then uncheaked every box

This worked for a while until i inported a playlist from my i tunes library.

so, I just went to my local files and deleted every song and now the songs play. 🙂

samuelmp

The MP3-Codec is the trick  in a new reinstallation of Windows 7.

 

http://www.free-codecs.com/mpeg_layer_3_codec_download.htm

 

Thanks!

KevinLousen

Use this guide http://www.tuneclone.com/guide.php it will solve your problems if you have purchased songs from Itunes 🙂

ste_fanny

If you right click on the song, at the bottom of the list, click on delete. It takes it out of your Spotify local files, but does nothing to the actual file on itunes,etc. I just retype the song/album query in the search box and listen from there. Hope that helps. It's super easy:).

My local files were working fine. Then I installed Windows 8 and none of my local files would play. Thought it might be an itunes problem, but I cannot get itunes to install at all, so I did this:

 

Open Spotify

 

Edit > Preferences > Local files

 

Uncheck all the boxes

 

Now all my playlists work.

 

I am assuming the following: This won't play your local files, but it will play the tracks that were previously streamed from your local files from another source within Spotify.

 

Now I wait for Spotify and itunes to sort out compatibility issues with Windows 8. Don't really care though, my house is rockin again.

tetra

I had the same issue and none of the fixes worked, untill I unchecked the Local Files check boxes in preferences as suggested, and then re-added my music folder using the Add Source button. All my songs work fine now.

 

Interestingly my library was listed as music and now after adding it again its c:\music

 

Edit:
WELL that did work initially, and now its back to not playing those files :S and doing the same no longer works... :[

 

Edit Again:

This problem is getting even worse, a song I was just listening too wouldnt play a second time round when I restarted the play list, the only solution it seems is to uninstall spotify and use something else! 😛

 

Edit yet again:

So the files that wont play only dont play when spotify goes onto the next song while playing a playlist, if I manually click a different song, then back to the one that doesnt play, it suddenly does plays, go figure :S

j_pipsox

Hi!

 

I've just had the exact same thing - went to play a local file and the song would come up, but there were no times on the bottom bar! They would play fine on my computer and all normal songs would play fine too!

I looked on here and no-one really had a solution, but I think I may have found something(?!)

Then, my phone no longer showed up on the 'Devices' list of Spotify program - was seriously cheesed off by now!

 

So - I uninstalled the app on my phone and the computer program, turned phone off and on, restarted PC.

Installed app and installed the program again!

Unchecked all local file import places, so I had no local files basically and set them not to sync on my phone.

I then re-checked to sync local files, they all came onto my PC fine and played good too.

Spotify then decided to start recognising my phone again (it just sorted itself out after a couple of days?)

I then re-synced my local files onto my phone and hey presto, they worked.

Not holding up much hope as to how long it'll last - but it does disappoint me how tragically shocking the customer service and the actual app and program are with Spotify, especially when we pay for it!

 

Hope this helps 🙂

avermat

I unchecked all the boxes under Preferences > Local Files and then re-added my music folder to the list and everything works smoothly now. Thanks guys!

TankOcean

I installed the codec, quiktime, have done everything in this thread and it's still not working. If I don't get this fixed today I'm going to cancel my spotify premium subscription because I don't pay $10 a month to deal with bull**bleep** like this

ChayPea

this worked perfectly for me after refusing to use any apple products whatsoever on my window machines thanks!

 

http://www.free-codecs.com/mpeg_layer_3_codec_download.htm

Butch

downloaded twice Spotify. WIll not play my I-Tunes files. Operating system is Windows 8

Peter__

@Butch wrote:

downloaded twice Spotify. WIll not play my I-Tunes files. Operating system is Windows 8


Hey! Welcome to the community 🙂 

 

Have you tried downloading and installing Apple Quicktime?

It appears to install the missing codecs.

 

Peter

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

spotify999

I just bought a new PC running Windows 8 and like others here my local files would not play. Happily, as suggested, when I downloaded Quicktime my local files started to play! Thanks for the advise.

Suggested posts

Env: prod