Spotify won't play "local files" songs!

Solved!
Reply

Spotify won't play "local files" songs!

barthelemy_gas
Visitor

Hi there!

 

When I want to play files from "local files", some of them won't play. I don't really understand why ?

They've been imported from itunes. The bottom bar doesn't show anything and the "point" has disappeared!

 

If any of you got an idea? 

Cheers! 

86 Replies

Cronnix
Regular

For me the issue was missing windows media player pack. Took while to figure out, fun times spotify is dependant on it. 

Blukerbeh
Newbie

Weirdly enough, I'm only having issues with this on my desktop, which is where I got the local files from in the first place. I downloaded the playlist through Spotify on my mobile device and it works just fine there. Using windows 8.

gerrun
Newbie

I just joined spotify and had the same problem. I found the problem (for me, using Windows 10 updated as of 18 May 2017) was to turn off MUSIC LIBRARY.  

Follow this:  Edit >Preference. It will bring you to the SETTINGS page. Scroll down until you come to LOCAL FILES. Under SHOW SONGS, you should have your file path (example: H:\MUSIC DISTRIBUTION) showing with the green switcher to the right lit to green (on). If you need to add your path and folder, click on ADD A SOURCE. Then scroll down a bit and make sure the MUSIC LIBRARY is NOT on (no green glow at the switch to the right). When I turned mine off, the unplayable MP3's became playable.  

NOTE: I'm not sure if you left the DOWNLOAD and WINDOWS MEDIA PLAYER on, it would work. I have mine off.  I hope this helps everyone who's having this problem. Good luck. 

Ohayoua
Casual Listener
Problem solved though I don't know how and can't claim credit for it.

bunder2016
Casual Listener

I can't get it to work on linux either.  1.0.49.125.g72ee7853

 

Added the directory, file shows up, click play and I get the "you can import it" message.  Clearing cache did nothing, although I'll also add that I didn't have a local-files.bnk file either.

Ohayoua
Casual Listener
Thank you for your response. I uninstalled and reinstalled it and that cured the problem. I don’t know if it will work with Linux, though.

Gabriel_Reis
Newbie

I logged in just to say Thank You!

SUGGESTED POSTS