Announcements

Your Music Failed to load/Browse not loading since 11 July 2014

Solved!
Reply
Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Casual Listener

Same problems! I guess there is a big server problem going on spotify!

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Regular

Exact same problem here too. Everything is working great on the android app for me but not so much on the desktop client. Clicking on Songs brings my collection up but when I click Albums or Artists I get "Your Music has failed to load". 

 

Another occurance I found was when trying to upgrade my account on Spotify site I received an error code.

 

Hope we can all get this sorted soon 🙂

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Newbie

same here.

 

MAC OSX. UK


And when it does eventually show infos on my playlists it says the playlist has been created by someone else !

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Regular

I feel your pain. I thought this was slightly weird too. Lets hope it's just server issues and there's a fix on the way hehe.

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Casual Listener

Just to let you know: as of this morning the account of my husband (which I mentioned earlier as working properly) has the same problem...

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Community Legend

UPDATE: I have managed to escalate this to one of the Spotify team and I'll let you know when I hear anything more.

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Regular

@Joe thanks a lot for this 🙂

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Community Legend

No worries - I just wish I could do more when stuff like this happens 🙂

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Newbie

Same isues here in UK... OSX 10.9.4 (13E28), browsing fails to load with continual spinning dots... albums and artists returns the error music failed to load. Some apps don't  load either. I've completely uninstalled and reinstalled... rebooted the rooter all to no avail. As with everyone the IOS app works fine. Three weeks into the free trial I'm wondering if my money will be better spent elsewhere, especially with the lack of response to my earlier email to customer support??

Highlighted

Re: Your Music Failed to load/Browse not loading since 11 July 2014

Newbie

I'm having similar problems. Search doesn't work at all, Browse just shows the circle of dots spinning forever. The rest of the functions seem unaffected, though I haven't tried them in-depth. Both search and browse work well in the web player.

 

 

Using Spotify 0.9.11.27.g2b1a638c. Windows Vista Home Basic. Have tried a clean reinstall.

SUGGESTED POSTS